[Pkg-tcltk-devel] Bug#550299: gitk: package depends explicitly on tk, wish may be more appropriate

Steffen Moeller steffen_moeller at gmx.de
Fri Oct 9 13:45:57 UTC 2009

Gerrit Pape wrote:
> On Fri, Oct 09, 2009 at 01:31:56PM +0200, Steffen Moeller wrote:
>>> Hi, please see http://bugs.debian.org/503113
>> I should have reopened that bug probably. With tk8.4 remaining unremovable for
>> gitk, and  r-core-dev depending on tk8.5, and me wanting to use the newer
>> version, I still suggest to somehow change the dependency. How about
>> tk(>=8.4)|tk8.5 ?
> Hmm, the report above suggest that you can remove tk8.4:
> On Wed, Oct 22, 2008 at 06:56:48PM +0200, Adeodato Sim? wrote:
>> Comments:
>>   * there is a "tk" pacakge, so "Depends: tk (>= 8.4)" would solve the
>>     concerns in #456423 that one can't just have tk8.5 installed.
> Was that wrong advice?

In my mind - yes.

$ LANG=C sudo dpkg --purge tk8.4 tk
dpkg: dependency problems prevent removal of tk:
 gitk depends on tk (>= 8.4).
dpkg: error processing tk (--purge):
 dependency problems - not removing
dpkg: dependency problems prevent removal of tk8.4:
 tk depends on tk8.4 (>= 8.4.16-2).
dpkg: error processing tk8.4 (--purge):
 dependency problems - not removing
Errors were encountered while processing:

You may argue that the problem is with the tk package, which should also allow
newer version of tk. For the moment it does not:

$ apt-cache show tk | grep Depends
Depends: tcl (= 8.4.16-2), tk8.4 (>= 8.4.16-2)

This is probably intentional, since it grants a guarantee for the availability
of a well-known version of tk. I personally find the explicit dependency on tcl
 wrong, though and would prefer for the tk package something like

Depends: tk8.4 (>= 8.4.16-2) | tk8.5 (>= 8.5.7-1)

I am CCing the tk maintainers mailing list, who have more of an oversight on
the issue than me.



More information about the Pkg-tcltk-devel mailing list