[Pkg-tcltk-devel] Bug#550299: gitk: package depends explicitly on tk, wish may be more appropriate

Jonathan Nieder jrnieder at gmail.com
Wed Feb 17 03:33:57 UTC 2010

tags 550299 + wontfix

Hi Steffen,

Steffen Moeller wrote:
> Gerrit Pape wrote:
>> On Wed, Oct 22, 2008 at 06:56:48PM +0200, Adeodato Simó wrote:

>>>   * there is a "tk" pacakge, so "Depends: tk (>= 8.4)" would solve the
>>>     concerns in #456423 that one can't just have tk8.5 installed.
>> Was that wrong advice?
> In my mind - yes.
> dpkg: dependency problems prevent removal of tk8.4:
>  tk depends on tk8.4 (>= 8.4.16-2).

Aggh, yes.  I am not all a fan of how the tk packages are set up.

> You may argue that the problem is with the tk package, which should also allow
> newer version of tk.

Yep.  I do not want to create more hacks, so I think this is in the
hands of the tk maintainers now.  See #570164 (gitk bug) and #516178
(tk bug).

A dependency on wish would be satisfied by tk8.3, which I think makes
it a nonstarter.  Marking wontfix.

Still, thanks for working towards a smaller disk footprint for Debian.
I do hope this gets fixed.


More information about the Pkg-tcltk-devel mailing list