[Pkg-tcltk-devel] gitk: package depends explicitly on tk, wish may be more appropriate

Jonathan Nieder jrnieder at gmail.com
Fri Feb 19 11:31:48 UTC 2010

On Fri, Feb 19, 2010 at 11:34:11AM +0100, Francesco P. Lovergine wrote:
> On Fri, Feb 19, 2010 at 04:16:33AM -0600, Jonathan Nieder wrote:
>> Francesco P. Lovergine wrote:

>>> If the program depends strictly on non default version, you have to use 
>>> tk8.5 (>= 8.5.7) | tk (>= 8.5.7)
>> Makes sense.  What should the program invoke instead of wish?
> wish8.5 or wish as second choice, but the program should also check 
> if it is using tk >= 8.5 in any case. So check $tk_version or see
> package(3tcl) to require a specific Tk version or what else.

gitk already uses {package require Tk 8.4}.  Since the tk8.5
dependency is just for a bug fix, I don’t think I should change that
expression (if some users want to “wish8.4 gitk” for some reason, I
don’t want to stop them).

I guess the new opening line should become

exec $(which wish8.5 wish | head -1) "$0" -- "$@"

.  Unfortunately, this means if a future version of Debian or some
alternate distribution uses Tk 8.6 by default, gitk will prefer 8.5,
but that’s not terrible.  The package can be changed again once the
default version is increased.

Thanks for the help.

More information about the Pkg-tcltk-devel mailing list