[Pkg-telepathy-maintainers] Bug#639667: [telepathy-gabble] Claims my server's certificate is self-signed

Maximilian Engelhardt maxi at daemonizer.de
Tue Jul 24 17:00:20 UTC 2012

Package: telepathy-gabble
Version: 0.16.1-1

I think this is the same problem I have. I tried three different jabber server 
of which I know they have valid certificates and other jabber clients validate 
them just fine, but telepathy-gabble always gives me this error that the 
certificate is self-signed. Tested with empathy and telepathy-kde.

I did enable telepathy-gabble logging, but couldn't find anything wrong in the 
logs. I seems to load system certificates from /etc/ssl/certs/ca-
certificates.crt fine, but somehow is unable to validate the server 
certificate. I tried searching for this problem on the internet, but all I 
found was this bug report or some people complaining about what seems to be 
the same problem on some Ubuntu forums. I also tried searching the upstream 
bugzilla, but couldn't find anything relevant.

So for me this looks a bit strange. It seems like only people from Debian or 
Ubuntu are affected, but I couldn't find any effort to track this down. So 
either there is something special about Debian (and Ubuntu) that triggers this 
bug only there or nobody tried it on other distributions or everybody just 
enabled the ignore ssl errors flag (which IMHO is a bad thing to do).

I also tried building the upstream git version of telepathy-gabble, but it has 
the same problem for me.

For me this very much looks like an upstream bug, however I wonder why this 
hasn't been noticed and reported anywhere then. So I will open an upstream bug 
about this issue soon, unless someone convinces me this is a Debian specific 

--- System information. ---
Architecture: amd64
Kernel:       Linux 3.4-trunk-rt-amd64

Debian Release: wheezy/sid
  500 testing         security.debian.org 
  500 testing         mirror.stusta.mhn.de 
  500 testing         ftp.de.debian.org 
    1 experimental    mirror.stusta.mhn.de 

--- Package information. ---
Depends                     (Version) | Installed
libc6                        (>= 2.7) | 
libdbus-1-3                (>= 1.1.1) | 
libdbus-glib-1-2            (>= 0.88) | 
libglib2.0-0              (>= 2.31.8) | 
libgnutls26            (>= 2.12.17-0) | 
libnice10                  (>= 0.1.0) | 
libsoup2.4-1               (>= 2.4.0) | 
libsqlite3-0               (>= 3.5.9) | 
libtelepathy-glib0        (>= 0.18.0) | 
libxml2                    (>= 2.7.4) | 

Package's Recommends field is empty.

Package's Suggests field is empty.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.alioth.debian.org/pipermail/pkg-telepathy-maintainers/attachments/20120724/cc1fe9bd/attachment.pgp>

More information about the Pkg-telepathy-maintainers mailing list