[pkg-uWSGI-devel] Bug#941432: uwsgi-core: Dependency libmatheval is getting out of bullseye

Pierre-Elliott B├ęcue peb at debian.org
Mon Sep 30 14:29:09 BST 2019


Source: uwsgi
Version: 2.0.18-4
Severity: serious

Dear maintainers,

uwsgi-core depends on libmatheval1, which future in the archive seems
compromised, this implies that src:uwsgi and all packages which depend
on it will get out of the archive sooner or later.

Do you have plans/solutions regarding this issue? Is it possible to drop
uwsgi-core dependency on libmatheval1?

Thanks for your help and your work with uwsgi!

Best regards,

-- 
PEB
Impacted as a mailman3-web maintainer.

-- System Information:
Debian Release: 10.1
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'stable-updates'), (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.19.0-5-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to fr_FR.UTF-8), LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to fr_FR.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages uwsgi-core depends on:
ii  libc6         2.28-10
ii  libcap2       1:2.25-2
ii  libjansson4   2.12-1
pn  libmatheval1  <none>
ii  libpam0g      1.3.1-5
ii  libpcre3      2:8.39-12
ii  libssl1.1     1.1.1c-1
ii  libsystemd0   241-7~deb10u1
ii  libuuid1      2.33.1-0.1
ii  libxml2       2.9.4+dfsg1-7+b3
ii  libyaml-0-2   0.2.1-1
pn  libzmq5       <none>
ii  zlib1g        1:1.2.11.dfsg-1

uwsgi-core recommends no packages.

Versions of packages uwsgi-core suggests:
pn  nginx-full | cherokee | libapache2-mod-proxy-uwsgi | libapache2-mod  <none>
pn  uwsgi-dev                                                            <none>
pn  uwsgi-extra                                                          <none>
pn  uwsgi-plugins-all                                                    <none>



More information about the pkg-uWSGI-devel mailing list