dependencies of libxine-xvdr

Reinhard Tartler siretart at
Thu Jun 28 07:55:53 UTC 2007

Hello Maintainers of libxine-xvdr,

Let me introduce myself, I'm Reinhard Tartler, and have taken over
maintenance of xine-lib. In fact, I'm maintaining it together with
Darren Salt, who is CC'ed in this email.

I have been notified from a user that the packages libxine-xvdr and
xine-lib are out of sync. We currently have xine-lib 1.1.7 in unstable,
wheras libxine-xvdr only provides a plugin for 1.1.2. I'd like to ask
you to recompile against the current xine-lib.

Speaking of it, I think you should declare tighter dependencies. I
hereby propose the the following:

Depends: libxine1 (<< 1.1.8), libxine1 (>= 1.1.7)

In the xine-lib source package I'm using a shlibs.local file to do this
for all xine-lib binary packages. I'd suggest that you do the same.

Btw, I don't think it is feasible to use my shlibs.local as real shlibs
file, because that would mean that all frontends (application linking to
libxine) would have to be recompiled on every new xine upstream version,
which is not intended at all.

I can also offer to add a versioned Breaks field in the xine-lib
packages against 'obsolete' versions of libxine-xvdr. However, I'd
rather like to urge you to tighten the dependencies on your packages,
because the Breaks field is only supported by apt 0.7, found in
unstable; support in dpkg is pending.

Thanks for your cooperation!

Reinhard Tartler, KeyID 945348A4
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 213 bytes
Desc: not available
Url : 

More information about the pkg-vdr-dvb-devel mailing list