Bug#312942: asterisk package install croaks with various errors

Robert Lister robl@lentil.org, 312942@bugs.debian.org
Sun, 12 Jun 2005 00:58:27 +0100

On Sun, Jun 12, 2005 at 02:24:37AM +0300, Tzafrir Cohen wrote:
> On Sun, Jun 12, 2005 at 12:13:46AM +0100, Robert Lister wrote:
> > On the first installation, it fell over with some error (I think it was some
> > chown commands that it failed to run) (I have a more or less clean sarge
> > build installed on Friday.)
> > 
> > It DID initially put the config files in place, but refused to start
> > asterisk as stuff seemed to have the wrong permissions, being installed as
> > "root" instead of "asterisk"
> Which files?

everything in /var/spool/asterisk, /etc/asterisk and /var/log/asterisk was
wrong permissions.

Unfortunately I wasn't paying much attention at the time to the error when
it installed (I'm a bit of a debian newbie so wasn't sure if this error was
important or not.)

> Any chance you tried to run 'asterisk' before that?

I installed, from aptitude, the asterisk package, but there was no 
asterisk on the box before that.

What may have happened is that I could have done "asterisk -vvvvvrc" to see 
if it was running or not, but as it didn't start, it was unabled to connect.

> > I tried channging permissions on various directories etc to be owned by
> > asterisk and not root, but I couldn't get it to work correctly, (even with
> > my previously working asterisk config files I copied over from the old box)
> > so I un-installed it and removed the various directories and tried a
> > re-install.
> What exactly is "re-install" ?

removing the asterisk package and putting it back again.

> Those files are marked as config files. Any changes to them may be
> recorded until you purge asterisk-config.
> Try:

tigger:~# dpkg --purge --force-depends asterisk-config
(Reading database ... 29103 files and directories currently installed.)
Removing asterisk-config ...
Purging configuration files for asterisk-config ...

tigger:~# apt-get install -f
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0B/61.2kB of archives.
After unpacking 295kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Selecting previously deselected package asterisk-config.
(Reading database ... 29057 files and directories currently installed.)
Unpacking asterisk-config (from .../asterisk-config_1%3a1.0.7.dfsg.1-2_all.deb) ...
Setting up asterisk-config (1.0.7.dfsg.1-2) ...
Setting up asterisk (1.0.7.dfsg.1-2) ...

That looks a bit more promising. 

It hasn't put in place /etc/init.d/asterisk though it has installed the
config files and the asterisk binary, so I removed and put it back again and
this time it has placed it:

dpkg --purge --force-depends asterisk-config
dpkg --purge --force-depends asterisk
apt-get -f
apt-get install asterisk

Out of interest, I just thought of something. If there was previously an
"asterisk" user in /etc/passwd, would that screw it up?