Bug#522436: /usr/bin/midori: symbol lookup error

Nelson A. de Oliveira naoliv at debian.org
Sun Apr 5 03:55:40 UTC 2009


On Sun, Apr 5, 2009 at 12:45 AM, Trent W. Buck <trentbuck at gmail.com> wrote:
>> The problem is that while [midori's] Build-Depends requires
>> libsoup>= 2.25, dpkg_shlibdeps doesn't correctly preserve this when
>> generating the Depends field.  I'll add a Conflicts (<< 2.25) [...]
>>> ii  libsoup2.4-1           2.24.3-2          an HTTP library implementation in
>>> ii  libwebkit-1.0-2        1.1.3-2           Web content engine library for Gtk
> Could this problem be webkit's fault?  I notice that webkit's -dev
> package requires libsoup 2.25, but the run-time libwebkit package
> doesn't.

It seems that it has been fixed in webkit 1.1.3-3 [1]
A binNMU should fix it, if I am not wrong.

[1] http://packages.qa.debian.org/w/webkit/news/20090327T213234Z.html

Thank you!

Best regards,

More information about the Pkg-webkit-maintainers mailing list