Bug#535626: Crash with "BadImplementation (server does not implement operation)"

Julien Cristau jcristau at debian.org
Tue Feb 9 00:35:02 UTC 2010

On Fri, Jul  3, 2009 at 21:44:38 +0200, Ulrich Eckhardt wrote:

> $ /usr/lib/webkit-1.0-2/libexec/GtkLauncher http://space-invasion.de
> open dsp: Device or resource busy
> The program 'GtkLauncher' received an X Window System error.
> This probably reflects a bug in the program.
> The error was 'BadImplementation (server does not implement operation)'.
>   (Details: serial 33 error_code 17 request_code 146 minor_code 5)


> - I actually tried to run midori through xtrace[2] but all I got was a messed-
> up X session which I could only recover from through a remote connection from 
> a different machine. Heaven knows what xtrace does with things it doesn't 
> understand itself...

xtrace doesn't modify the data it gets from the X server and client, it
tried to decode it if it can, but in any case passes it on unmodified.

> - Looking at /usr/include/xcb/glx.h, 146 is defined as XCB_GLX_IS_TEXTURE, 
> maybe the toolkit in question tries to use GLX (which I otherwise have 
> activated, as glxinfo tells me) without querying its availability first?

You're not looking in the right place.  The request code (in this case
146) should be looked up in 'xdpyinfo -queryExt'.  Look for an extension
with that opcode.  Then look for request number 5 in that extension.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/pkg-webkit-maintainers/attachments/20100209/ff7cb42e/attachment.pgp>

More information about the Pkg-webkit-maintainers mailing list