Bug#595794: webkit: uninstallable on amd64

Michael Gilbert michael.s.gilbert at gmail.com
Mon Sep 6 17:48:10 UTC 2010

package: webkit
version: 1.2.4-1
severity: grave

the amd64 package is currently uninstallable due to dependency on gtk2 >= 2.21, but only version 2.20 is available in unstable.  the package was probably built in the wrong environment again:

    $ sudo apt-get install libwebkit-1.0-2
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
     libwebkit-1.0-2 : Depends: libgdk-pixbuf2.0-0 (>= 2.21.6) but it is not going to be installed
                   Depends: libgtk2.0-0 (>= 2.21.6) but 2.20.1-1+b1 is to be installed
    E: Broken packages

More information about the Pkg-webkit-maintainers mailing list