Bug#748456: liferea: crashes when selecting any feed

Johannes Schauer j.schauer at email.de
Thu May 22 12:56:47 UTC 2014


Quoting Emilio Pozuelo Monfort (2014-05-22 14:32:02)
> On 22/05/14 13:48, Alberto Garcia wrote:
> > On Sat, May 17, 2014 at 02:30:00PM +0200, Johannes Schauer wrote:
> > 
> >> Package: liferea
> >> Version: 1.10.8-1
> >> Severity: grave
> >> Justification: renders package unusable
> >>
> >> Hi,
> >>
> >> steps to reproduce:
> > 
> > I didn't use a chroot but installed liferea in my own system and I
> > can't reproduce the bug, everything seems to work normally. Javascript
> > is enabled.
> > 
> >>From your backtrace, the problem is in VMEntryScope::requiredCapacity()
> > 
> >     RELEASE_ASSERT(m_stack.size() >= requiredCapacity);
> > 
> > Can you reproduce it 100% of the time?

Yes. I tried to start liferea five times.

> > Did you try in a different system?

No. I thought using a chroot would avoid any problems because of my system
configuration. Hence I found it unnecessary to try on a different system.

> Besides, why are you running liferea from a chroot?

To make sure that my system configuration cannot be the reason for this bug to

> And what version of webkit and javascriptcore do you have? Next time please
> use reportbug.

I ran my initial steps to reproduce again and here are the package versions:

Versions of packages liferea depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.20.0-2
ii  gir1.2-gtk-3.0                               3.12.2-1
ii  gir1.2-peas-1.0                              1.10.0-2
ii  libatk1.0-0                                  2.12.0-1
ii  libc6                                        2.18-7
ii  libcairo2                                    1.12.16-2
ii  libgdk-pixbuf2.0-0                           2.30.7-1
ii  libgirepository-1.0-1                        1.40.0-2
ii  libglib2.0-0                                 2.40.0-3
ii  libgtk-3-0                                   3.12.2-1
ii  libindicate5                                 0.6.92-2
ii  libjson-glib-1.0-0                           1.0.0-1
ii  libnotify4                                   0.7.6-2
ii  libpango-1.0-0                               1.36.3-1
ii  libpeas-1.0-0                                1.10.0-2
ii  libsoup2.4-1                                 2.46.0-2
ii  libsqlite3-0                       
ii  libwebkitgtk-3.0-0                           2.4.2-1
ii  libxml2                                      2.9.1+dfsg1-3
ii  libxslt1.1                                   1.1.28-2
ii  liferea-data                                 1.10.8-1
ii  python-gi                                    3.12.1-1
pn  python:any                                   <none>

Versions of packages liferea recommends:
ii  dbus                     1.8.2-1
ii  dbus-x11                 1.8.2-1
ii  gir1.2-gnomekeyring-1.0  3.8.0-2
ii  gnome-icon-theme         3.12.0-1
ii  gnome-keyring            3.12.0-2
ii  steadyflow               0.2.0-1

Versions of packages liferea suggests:
pn  network-manager  <none>

I can still reproduce the problem with current Debian sid and liferea quits
once I select any feed with the WTFCrash+0x17 error.

In case you do not consider this bug valid because I execute liferea inside a
chroot: I get the same backtrace when executing liferea on my host system.
Though there I can of course not vouch that my local configuration influences
my result.

Also, this error is not local to liferea. Other programs using
libjavascriptcoregtk fail with the same error. If I replace "apt-get install
liferea" with "apt-get install surf" in my instructions above and then do:

$ sudo chroot debian-sid surf google.com

Then surf will also quit with a WTFCrash+0x17 error just as liferea did. This
error with surf is reproducible on my host system as well.

David Smith mentioned that he could only reproduce the error if he hadnt
installed a regular DE (such as icewm). I do not have a regular DE installed on
my host machine either (and naturally also not inside the chroot).

If liferea, surf or other applications using libjavascriptcoregtk need a DE or
anything else that a minimal chroot (and my host system) doesnt have and which
makes it crash, then it should be mentioned in its Depends.

cheers, josch

More information about the Pkg-webkit-maintainers mailing list