Bug#783293: Aw: Re: Bug#783293: browsers crash with 'illegal instruction' on i586

hikaru.debian at web.de hikaru.debian at web.de
Thu Apr 30 17:41:25 UTC 2015

> From: Bernhard Übelacker <bernhardu at vr-web.de>
> I tried as a workaround to build a libqtwebkit package with attached 
> little modification (does disable JIT, like for other archs).
> With this the browser does not crash.

confirmed on real hardware.

> From: Lisandro Damián Nicanor Pérez Meyer <perezmeyer at gmail.com>
> Hi Hikaru! Is there any chance for you to see if this also happens with arora? 
> The difference here is that arora currently uses Qt5 and it would be useful to 
> know if the bug is also reproducible there.

I tried, but unfortunately my i586 machine only has 320MB RAM and I can't upgrade it.
It's already swapping heavily to even start the browser. Getting any website loaded
before the Stretch release might be difficult.

> From: Sune Vuorela <sune at debian.org>
> I agree that just disabling the JITter is not an option. If someone improves 
> the jitter, or making jitting optional for these architectures, we can look 
> into it again. Until a patch shows up that does that, I'm going to mark this 
> wontfix from the qt side of things.

I totally understand your reasoning and I have next to no knowledge about Debian bug
report tags. But from my layman's point of view marking it as 'wontfix' seems a
little "unfortunate". It might be misinterpreted as: "We don't care that our package
is broken on half of the architecture (i386)."
Wouldn't 'moreinfo' be more appropriate as in?: "We need more info on how to fix it
in a way that works for i586 but doesn't put i686 on a disadvantage."
After all i586 is the minimum requirement all 'i386' packages should work on, right?

> From: Bernhard Übelacker <bernhardu at vr-web.de>
> On Tue, 28 Apr 2015 21:40:34 +0200 Emilio Pozuelo Monfort <pochu at debian.org> wrote:
> > If you can try webkitgtk, you should be able to set JavaScriptCoreUseJIT=0 in
> > the environment as a workaround.
> I did a "export JavaScriptCoreUseJIT=0".
> But still qupzilla/libQtWebKit and xombrero/libwebkitgtk-3.0/libjavascriptcoregtk-3.0
> received the signal SIGILL as before (inside qemu VM, '-cpu pentium').


kind regards

More information about the Pkg-webkit-maintainers mailing list