[Pkg-xen-devel] Bug#388352: xen-hypervisor-3.0-unstable-1-amd64: veth0 is missing

Bin Tian tianbin at cernet.edu.cn
Wed Sep 20 04:11:29 CEST 2006

Package: xen-hypervisor-3.0-unstable-1-amd64
Version: 3.0-unstable+hg11292-2
Severity: important

My server is a dell 2950 server. 

Before the dom0 rebooting bug ocurred, xen was well even for hvm domU. 
By now i have tried xen-hypervisor-3.0-amd64 (3.0.2+hg9697-2) and
xen-hypervisor-3.0-unstable-1-amd64 (3.0-unstable+hg11292-2), 
but both of them are unusable for me.

for xen-hypervisor-3.0-amd64:
The vnc server won't start and the hvm domU won't boot and blocks in 
'b' state. The domU with modified kernel boots ok.
When I run xm, there is a warning which says there is no
xen utils with version 3.0.2-3-1 installed, and falling back to

for xen-hypervisor-3.0-unstable-1-amd64:
If I choose the linux-image-2.6.16-2-xen-em64t-p4 as the dom0 kernel,
the rebooting bug appears.

If I choose the linux-image-2.6.17-2-amd64 as the dom0 kernel, I can
enter the box. But when I run /etc/xen/scripts/network-bridge start, it 
told me that:

Link veth0 is missing.
This may be because you have reached the limit of the number of
that the loopback driver supports.  If the loopback driver is a module,
may raise this limit by passing it as a parameter (nloopbacks=<N>); if
driver is compiled statically into the kernel, then you may set the
using loopback.nloopbacks=<N> on the domain 0 kernel command line.

The following is FYI

dell-2950:~# uname -a
Linux dell-2950 2.6.17-2-xen-amd64 #1 SMP Wed Sep 13 18:35:45 CEST 2006
x86_64 GNU/Linux
dell-2950:~# xm list
Name                              ID Mem(MiB) VCPUs State  Time(s)
Domain-0                           0     1883     8 r-----    42.9
dell-2950:~# ifconfig -a | egrep "veth|vif"
dell-2950:~# dpkg -l | grep 'xen-'
ii  linux-image-2.6-xen-em64t-p4        2.6.16+0.2             Linuxkernel 2.6 image on Intel em64t P4 mac
ii  linux-image-2.6.16-2-xen-em64t-p4   2.6.16-18              Linuxkernel 2.6.16 image on Intel em64t P4
ii  linux-image-2.6.17-2-xen-amd64      2.6.17-9               Linux2.6.17 image on AMD64
ii  linux-modules-2.6.16-2-xen-em64t-p4 2.6.16-18              Linuxkernel modules 2.6.16 image on Intel e
ii  linux-modules-2.6.17-2-xen-amd64    2.6.17-9               Linux2.6.17 modules on AMD64
ii  xen-hypervisor-3.0-unstable-1-amd64 3.0-unstable+hg11292-2 The XenHypervisor on AMD64
ii  xen-ioemu-3.0-unstable              3.0-unstable+hg11292-2 XENadministrative tools
ii  xen-linux-system-2.6.17-2-xen-amd64 2.6.17-9               XENsystem with Linux 2.6.17 image on AMD64
ii  xen-utils-3.0-unstable-1            3.0-unstable+hg11292-2 XENadministrative tools
ii  xen-utils-common                    3.0+hg11292-2          XENadministrative tools - common files

I think it's not a nlookbacks problem, because everything is the default
installation. And before installing xen unstable, I purged the installed
xen-hyphervisor-3.0-amd64 packages.

Best regards, 
Bin Tian

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.17-2-xen-amd64
Locale: LANG=zh_CN, LC_CTYPE=zh_CN (charmap=GB2312)

Versions of packages xen-hypervisor-3.0-unstable-1-amd64 depends on:
ii  xen-utils-3.0-uns 3.0-unstable+hg11292-2 XEN administrative tools

xen-hypervisor-3.0-unstable-1-amd64 recommends no packages.

-- no debconf information

More information about the Pkg-xen-devel mailing list