Bug#389836: [Pkg-xen-devel] Bug#389836: xen-hypervisor-3.0-unstable-1-amd64: HVM domU won't start

Bin Tian tianbin at cernet.edu.cn
Thu Sep 28 08:51:48 CEST 2006

I find that the qemu-ifup is very simple, so I make a copy of qemu-ifup 
in /etc/xen/ directory. This time, the domU started and I saw the boot 
screen of BIOS in vncviewer. But the BIOS said:
CDROM boot failure code: 0002
Boot from CD-Rom failed.
FATAL: Could not read from the boot disk.

I'm sure that the iso file is well. And I tried to start another domU 
which runs windows, and got the same result: CDROM boot failure.

Bin Tian.

Bin Tian wrote:
> Thanks for your quick response.
> The package xen-utils-common is already 3.0+hg11624-1. And I make some 
> correction in the dom config according to the example, but the domU 
> still cann't start. 
> I checked the log in /var/log/xen/. No error in xend.log, but 
> qemu-dm.log tell me that:
> domid: 3
> qemu: the number of cpus is 2
> /etc/xen/qemu-ifup: could not launch network script
> Could not initialize device 'tap'
> And the file with name 'qemu-ifup' is not in /etc/xen/ but in
> /etc/xen/scripts
> dell-2950:/usr/lib/xen-ioemu-3.0-unstable/bin# strings qemu-dm | grep 
> qemu-ifup
> /etc/xen/qemu-ifup
> I think that qemu-dm should be patched.
> Best regards,
> Bin Tian
> Bastian Blank wrote:
>> On Thu, Sep 28, 2006 at 09:26:06AM +0800, Bin Tian wrote:
>>> The HVM domU won't start. The following is the config (comments
>>> stripped).
>> Please check for the existance of /usr/lib64/xen/bin/qemu-dm which you
>> defined as device_model. After that upgrade to xen-utils-common
>> 3.0+hg11624-1 and check
>> /usr/share/doc/xen-utils-common/examples/xmexample.hvm.gz.
>> Bastian
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.alioth.debian.org/pipermail/pkg-xen-devel/attachments/20060928/6af05510/attachment.html

More information about the Pkg-xen-devel mailing list