[Pkg-xen-devel] The debian dom0 64 bits kernel crashes at boot time

Thomas Goirand thomas at goirand.fr
Wed Nov 26 02:24:57 UTC 2008

Ian Campbell wrote:
> On Wed, 2008-11-26 at 01:41 +0800, Thomas Goirand wrote:
>> Paul van der Vlis wrote:
>>> I also use this kernel, without problems. Do you use this kernel?
>>> http://packages.debian.org/lenny/linux-image-2.6.26-1-xen-amd64
>>> version 2.6.26-10.
>>> xen2:/usr/local/sbin# uname -a
>>> Linux xen2.build2be.nl 2.6.26-1-xen-amd64 #1 SMP Sat Nov 8 21:20:04 UTC
>>> 2008 x86_64 GNU/Linux
>> I did, and as I told you, it crashes in less than 2 seconds at boot
>> time. In fact, I tried BOTH the -8 and then -10, and they do the same.
> Can we have a full bug report on that issue please (or a pointer to an
> existing one, I must have missed it).

How do you suggest me to do such log? It's hard to give because it's
rebooting one second after it crashes. If I'm not mistaking it's
crashing in a setup_cpu function (I don't remember the exact name).

> You mean a Linux kernel with CONFIG_XEN=y? (some people say "Xen kernel"
> when they mean "Xen hypervisor").

Yes, with dom0 support.

> If you meant the former then you compile it in just the same way as a
> non-CONFIG_XEN kernel, i.e. with make-kpkg or simply by hand, or maybe
> with "make deb".
> If you mean the latter then I don't think there is a "Debian way" over
> and above apt-get source, debuild and friends like any other package.

By hand, I know how. With make-kpkg as well. But how do I do if I want
to create the exact same linux-image-2.6.26-1-xen-amd64 as you did,
using YOUR sources? I tried doing a dget on the .dsc, then doing
dpkg-buildpackage, but this didn't produce the expected package, plus
it's very long, as I saw it was building about 5 kernels (without
virtulalization, vserver, etc.) when I really only need the Xen one to
try to debug it...

One last thing I have in mind. My laptop comes with a e1000e ethernet
and 5300 wifi (both from Intel). Both of them only works on 2.6.27,
before it's either buggy or simply not working at all. Should I try to
create a patch against the current Debian kernel (kernel 2.6.26) so it
backports the drivers from 2.6.27, and it's included in Debian? I think
I could work on that if that helps having support for this hardware.



More information about the Pkg-xen-devel mailing list