[pkg-xtuple-maintainers] Bug#724305: Bug#724305: postbooks: Does not work on postgres 9.3

Daniel Pocock daniel at pocock.com.au
Tue Sep 24 21:38:43 UTC 2013

On 23/09/13 18:03, Daniel Pocock wrote:
> On 23/09/13 17:50, Felipe Sateler wrote:
>> On Mon, Sep 23, 2013 at 12:16 PM, Daniel Pocock <daniel at pocock.com.au> wrote:
>>> On 23/09/13 17:07, Felipe Sateler wrote:
>>>> Package: postbooks
>>>> Version: 4.0.2-3
>>>> Severity: important
>>>> Tags: upstream
>>>> Postbooks relies on functionality removed in 9.2. After setting up the
>>>> quickstart schema, trying to login yields:
>>>> A System Error occurred at login2.cpp::344:
>>>> ERROR:  column "procpid" does not exist
>>>> LINE 1: SELECT pg_try_advisory_lock(datid::integer, procpid)
>>>>                                                     ^
>>>> QUERY:  SELECT pg_try_advisory_lock(datid::integer, procpid)
>>>>      FROM pg_stat_activity
>>>>     WHERE(procpid = pg_backend_pid())
>>>> CONTEXT:  PL/pgSQL function login(boolean) line 10 at PERFORM
>>>> (42703)
>>>> procpid was renamed to pid in 9.2 and is not coming back[1].
>>>> Filing as important because 9.1 is still installable (thus possibly not
>>>> RC), but as the default postgres version is 9.3 this should really be
>>>> fixed soon.
>>> Thanks for this feedback
>>> I will check the PostgreSQL 9.3 plans from upstream.  They also have a
>>> new version (4.2) in beta, that could go on a branch in the Debian
>>> postbooks VCS (and maybe experimental) for testing with PostgreSQL 9.3.
>>> Did you do any further testing with 9.3 to see if further problems exist?
>> No, I was trying to give postbook a test-drive based on your recent
>> blog post. I've stopped after this problem.
> Ok, thanks for the feedback.  I've been using it with PostgreSQL 9.1 in
> wheezy
> I'll update you when a newer package is ready or when there is other
> feedback from upstream

Latest updates:

- upstream only supports up to v9.1 inclusive with their current
production releases.  Looking in their repository, it appears that their
upcoming 4.2.0 (currently a beta) will also have this bug on v9.3

- I've put in a server version check at startup, it is a patch in the
Debian package.  It will give users an explanatory popup message if they
have an unsupported PostgreSQL version so they won't be faced with this
unpleasant error.  This is in the 4.0.2-5 package that I just uploaded

More information about the pkg-xtuple-maintainers mailing list