[pkg-xtuple-maintainers] Bug#892750: postbooks: PostgreSql version too new for PostBooks client

Arjen Balfoort arjenbalfoort at solydxk.com
Mon Mar 12 14:28:18 UTC 2018

Package: postbooks
Version: 4.10.0-2
Severity: normal

Dear Maintainer,

   * What led up to the situation?
I installed Postbooks from the Debian Stretch repository with:
sudo apt-get install postbooks postbooks-schema-quickstart postbooks-updater postgresql postgresql-contrib postgresql-plv8 pgadmin3

I initiated and configured the database and the client successfully but whenever I start the client the following message is shown:

    The database server is at version PostgreSQL 9.6.7 on x86_64-pc-linux-gnu, compiled by gcc (Debian 6.3.0-18) 6.3.0 20170516, 64-bit but xTuple ERP only supports from 9.3.0 up to but not including 9.6.0.

   * What exactly did you do (or not do) that was effective (or
I installed postbooks from unstable (version 4.10.1-1) but that version had the same issue.

   * What was the outcome of this action?
Starting PostBooks always shows the above mentioned message.

   * What outcome did you expect instead?
The PostBook client should support the PostgreSql version provided by Debian Stretch.

-- System Information:
Distributor ID:	SolydXK
Description:	SolydK 9 64-bit
Release:	9
Codename:	solydxk-9
Architecture: x86_64

Kernel: Linux 4.9.0-6-amd64 (SMP w/1 CPU core)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE= (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages postbooks depends on:
ii  libc6                      2.24-11+deb9u3
ii  libdmtx0a                  0.7.4-2
ii  libgcc1                    1:6.3.0-18+deb9u1
ii  libgl1-mesa-glx [libgl1]   13.0.6-1+b2
ii  libopenrpt1v5              3.3.12-2
ii  libqt5core5a               5.7.1+dfsg-3+b1
ii  libqt5designer5            5.7.1-1
ii  libqt5designercomponents5  5.7.1-1
ii  libqt5gui5                 5.7.1+dfsg-3+b1
ii  libqt5help5                5.7.1-1
ii  libqt5network5             5.7.1+dfsg-3+b1
ii  libqt5printsupport5        5.7.1+dfsg-3+b1
ii  libqt5qml5                 5.7.1-2+b2
ii  libqt5quick5               5.7.1-2+b2
ii  libqt5script5              5.7.1~20161021+dfsg-2
ii  libqt5scripttools5         5.7.1~20161021+dfsg-2
ii  libqt5serialport5          5.7.1~20161021-2
ii  libqt5sql5                 5.7.1+dfsg-3+b1
ii  libqt5sql5-psql            5.7.1+dfsg-3+b1
ii  libqt5webchannel5          5.7.1-2
ii  libqt5webkit5              5.7.1+dfsg-1
ii  libqt5websockets5          5.7.1~20161021-4
ii  libqt5widgets5             5.7.1+dfsg-3+b1
ii  libqt5xml5                 5.7.1+dfsg-3+b1
ii  libqt5xmlpatterns5         5.7.1~20161021-3
ii  libstdc++6                 6.3.0-18+deb9u1
ii  libxtuplecommon1           4.10.0-2
ii  zlib1g                     1:1.2.8.dfsg-5

postbooks recommends no packages.

Versions of packages postbooks suggests:
ii  postbooks-schema-demo        1:4.10.0-2
ii  postbooks-schema-empty       1:4.10.0-2
ii  postbooks-schema-quickstart  1:4.10.0-2
ii  postbooks-updater            2.4.0-3

-- no debconf information

More information about the pkg-xtuple-maintainers mailing list