[Python-apps-team] Bug#499580: mayavi2: rendering issues

Varun Hiremath varunhiremath at gmail.com
Fri Oct 3 22:04:09 UTC 2008

Hello Prabhu,

On Fri, 03 Oct, 2008 at 11:18:35PM +0530, Prabhu Ramachandran wrote:
> Varun Hiremath wrote:
>> I am facing some rendering issues with mayavi2. Please look at this
>> bug report:
>> http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=499580
>> Could there be any issues with wxgtk2.8, because earlier I was using
>> wxgtk2.6? BTW, if both the versions exist which one will be used by
>> mayavi2?
> You almost definitely have an Intel GMA950 or similar card on your  
> machine.  There is a known bug in X/the intel driver that causes this.
> See this:
> http://bugs.freedesktop.org/show_bug.cgi?id=16072

Bingo! I have Intel GM965/GL960 graphics card and I get the exact same
error when I run:

$$ MESA_DEBUG=1 python contour.py

$$ Mesa warning: couldn't open libtxc_dxtn.so, software DXTn compression/decompression unavailable
$$ Mesa warning: glEnable(GL_DEPTH_TEST) but no depth buffer

I am using xserver-xorg-core 1.4.2 and libgl1-mesa-dri 7.0.3. The
versions that seem to fix this problem -- xserver 1.5.0 and
libgl1-mesa-dri 7.1 are both available in debian/experimental, though
I haven't tried them yet.

> from a message by Colin on enthought-dev.  It would be great if someone  
> with the problem could figure out if this is really a Xserver problem or  
> the intel driver problem and try and get this into Debian quickly.
>> Also, was some "explorer" function removed from mayavi2 in the new
>> version?
> Not sure.  Envisage plugins have changed so the explorer may not be  
> exposed in the shell, however, I am not sure where the explorer is in  
> the 3.x code base or if it works at all.  That was a Pyface/traits  
> package that I did not write... :(

Okay, thanks. Should I ask on enthought-dev?


Varun Hiremath
Ph.D. Student,
Cornell University,
Ithaca, NY

More information about the Python-apps-team mailing list