[Python-apps-team] Bug#844081: Reproducer

Filip Pytloun filip at pytloun.cz
Sun Nov 20 09:03:04 UTC 2016


I tried to reproduce the issue in my environment with:

i=0;while true;do python -m pytest tests;ret=$?;i=$[ $i+1 ];echo "Run: $i"; [ $ret -ne 0 ] && break; done

and in similar way with pbuilder that I am using and FTBFS didn't ever
happen (tried 50+ builds).

I have suspicion that these test failures occurs only on slower, eg.
one CPU machines as something similar happens with vdirsyncer as well.
Unfortunately running tests during build is always fragile and it seems
that what's working in one environment may be FTBFS for anyone else :-(

I will give it some more time to debug and reproduce (can you try the
same test on VM with more than 1 CPU?)

But as both CI and reproducible builds are passing fine, I would suggest
lowering the severity as this issue doesn't seem to be critical enough
to automatically remove package from testing.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://lists.alioth.debian.org/pipermail/python-apps-team/attachments/20161120/36e97ae1/attachment-0001.sig>

More information about the Python-apps-team mailing list