[Python-modules-commits] [python-pykka] annotated tag v0.12 created (now 5a39dd7)
Stein Magnus Jodal
jodal at moszumanska.debian.org
Sat Nov 7 20:22:53 UTC 2015
This is an automated email from the git hooks/post-receive script.
jodal pushed a change to annotated tag v0.12
in repository python-pykka.
at 5a39dd7 (tag)
tagging 0762755e21140f6eadedc57a69907b0de887e5bc (commit)
replaces v0.11.1
tagged by Stein Magnus Jodal
on Wed Mar 30 23:23:24 2011 +0200
- Log -----------------------------------------------------------------
Release v0.12
Stein Magnus Jodal (37):
Add py32 to tox.ini
Rename post_start() to pre_start() to adhere to Akka's naming
Add post_stop() hook to Actor
Add pre_start() and post_stop() to Actor example
Add NullHandler to logger as recommended by stdlib docs
Log exceptions that are returned to the caller on debug level in case the caller ignores them
Log unhandled exceptions to ease debugging
Document how to use logging in Pykka
Make both actor_ref and actor_proxy available in test
Add docstring to Timeout exception
Add ActorRef.is_alive() and check if actor is alive before it is used by any ActorRef method
Move pykka.future.Timeout to pykka.Timeout
Alias all Pykka imports to avoid importing Pykka classes from the wrong module
Make non-gevent tests run under Python 3.1 and 3.2
Make all tests pass on Python 3.2
Make all tests pass on Python 3.1
Move TestLogHandler to __init__ for reuse
Log unexpected messages instead of raising NotImplementedError if react() is not implemented
Fix typo
Ignore 'pykka' prefix in docs' modules index
Small docstring improvements
Hide imports from namespace
Ignore invalid pylint warnings/errors
Use _is_callable_attribute() instead of redefining callable() for Python 3.x
Improve docstring
Make Actor.actor_runnable private
Greatly improve testing of hooks
Add on_failure() hook
Move a logging test from actor_test to logging_test
Stop actor properly on failure
Replace 'UUID' with 'URN' in docstring to be consistent
Catch Exception instead of BaseException
Stop all actors on KeyboardInterrupt
Rename Actor.pre_start() to on_start()
Rename Actor.post_stop() to on_stop()
Rename Actor.react() to on_receive()
Release v0.12
-----------------------------------------------------------------------
No new revisions were added by this update.
--
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/python-modules/packages/python-pykka.git
More information about the Python-modules-commits
mailing list