[Python-modules-commits] [python-digitalocean] annotated tag upstream/1.0.2 created (now c2a9501)
Andrew Starr-Bochicchio
asb at moszumanska.debian.org
Tue Jun 20 00:31:43 UTC 2017
This is an automated email from the git hooks/post-receive script.
asb pushed a change to annotated tag upstream/1.0.2
in repository python-digitalocean.
at c2a9501 (tag)
tagging bd2fd16d1c06cdc02a46132c6b115581abcdc06a (commit)
tagged by Andrew Starr-Bochicchio
on Mon Sep 29 22:14:36 2014 -0400
- Log -----------------------------------------------------------------
Upstream version 1.0.2
Alex Tokar (1):
fixed key error bug
Andrew Starr-Bochicchio (18):
Initial work on porting to DigitalOcean's APIv2.
Port Region object and get_all_regions().
Port Size object and get_all_sizes().
Port digitalocean/Image.py, get_all_images(), get_my_images(), and get_global_images().
Support renaming Images.
We're POSTing not PUTing, so call it that.
Initial work on Domains.
Fix hair pulling stupidity. :boom:
Complete porting of Domain.
Port SSHKeys.
Port the examples in README.md
Initial work on a test suite. Currently only tests read actions, but it's a start.
One too many 'not's
urlparse does strange things.
Fix infinite loop when dealing with pagination.
Update tests for the release of the NYC3 region.
Test that all 'global' images are public, and that all 'my' images are private.
Imported Upstream version 1.0.2
Andrey Vagin (8):
Fix setting attributes for Kernel objects
get_kernel_available() gets kernels from all pages
Set the "type" attribute to change_kernel
typo fix
HTTP has more than one success code
Fix URL to create a droplet
ssh_keys must be an array
The creation response doesn't have the "actions" key
Chris Lamb (1):
Use PHP "arg[]" syntax when specifying ssh_keys.
Christian Buerger (1):
Fixed SSH keys (at least for me)
Clumsical (2):
Added SSHKey object
Added Create/Edit/Destroy methods for SSHKey
D. Yu (3):
Remove all trailing whitespace.
Correct arguments for Droplets.take_snapshot()
Correct API used by Droplet.rebuild()
Francesc Ortiz (3):
support for editing DNS records
remove unused lines
update comment
Johny Jose (1):
added option to enable backup on droplet creation
Jon Eisen (1):
Add scrub_data option to destroy.
Julio David Quintana (1):
Add 'created_at' to Droplet object
Kerry Ivan Kurian (1):
fix syntax error under Python3
Kyle Kelley (2):
Set scrub_data to True by default.
Adhere to DigitalOcean's spec on data scrub
Kyle Stevenson (1):
Fixed example syntax
Lorenzo Setale (164):
Initial commit
Created Droplet Object
Created file requirements to automatically install dependencies via pip
Created Image Object
Created Size Object
Created Region Object
Created Manager object
Implemented __init__.py with new objects
Created setup.py file
Updated package information with current github repository as URL.
Fixed problem with indentation
Renamed digitalocean packate to python-digitalocean
Upgraded to 0.2 version
Changed Description
Added MANIFEST to ignore file
Improved Readme.md with an example
Improved long_description when installing from source
Upgraded to 0.2.2 version
Merge pull request #1 from darylyu/master
New version 0.2.3
Merge pull request #2 from rdgreis/master
Improved code to use "load" function instead of call API when Event object is defined.
0.2.4
Removed client_id and api_key from __init__ of Event
Merge pull request #3 from rdgreis/master
Version = 0.2.5
Merge branch 'master' of git://github.com/rdgreis/python-digitalocean into rdgreis-master
Updated elements in Readme file
Updated to 0.2.6 version
Fixed author
Readme now is web-site ready.
Improved Header
Fixed links
Merge pull request #5 from samdobson/master
Upgraded to 0.2.7 version
Merge branch 'rdgreis-master'
Increased version
Merge pull request #6 from peterlandry/master
New version
Merge pull request #8 from clumsical/master
Version 0.3 released!
Merge pull request #9 from pomarec/master
Implemented rnwolf suggestion
New version
Added Image function to handle images.
New version
Merge pull request #11 from xela7/master
Using the new error message in API
New Release 0.4.2
Merge pull request #12 from sztanko/master
Merge pull request #13 from kkurian/master
Removed "print" function.
New release
Merge pull request #14 from koalalorenzo/pr/13
Merge pull request #15 from katnegermis/master
Using a single style to get value from dictionary.
Removed non used moduled imported
New release ( 0.5 )
Merge pull request #16 from herrbuerger/master
New Version 0.5.1
Fixing a example problem. ( issue #18 )
Merge pull request #20 from yanatan16/patch-1
Merge pull request #21 from rgbkrk/patch-1
Added License
New version!
Merge pull request #23 from hypatia1/master
Merge pull request #24 from atrniv/master
New version released
Merge pull request #25 from francescortiz/master
Updating my personal website.
Merge pull request #26 from kylestev/patch-1
Merge pull request #28 from munhitsu/master
Merge pull request #31 from davidquintana/master
Merge pull request #32 from dmaust/master
Merge pull request #34 from peterlandry/master
New version.
Merge pull request #35 from andrewsomething/apiv2
Update README.md
Update README.md
Merge pull request #40 from andrewsomething/tests
Merge pull request #39 from lamby/master
Created a new Ideal basic API class.
Created __call_api (basic example version, it will be overwritten)
Importing request module
Renamed __call_api into __get_data to make a KISS method that will get the data from a URL. This is a big improvement because will help to understand what URL is called in a specific method.
Action object "migrated" to the new base api class.
Defining properties in the right place/method.
Renamed the method to get_data to have a KISS access to it :)
Removed call_api (not useful anymore)
Raising an error in case the token is not provided and returning the data from the call in get_data method.
Using the new BaseAPI class (to be tested)
If no endpoint is specified ( we add it automatically )
Hiding the full URL, but writing it in a comment. In this way all the developers can choose or switch to a "testing machine"
Better style in the code ( space = readability! )
Droplet object now uses the knew BaseAPI class
Using the new end_point method.
Using a customized version of the get_data method to perform some actions on POST calls.
Improved Action class using a better class "style"
Rewrote Image class using the new BaseAPI and fixed bugs.
Removed call_api: not useful anymore
Manager rewritten using the new BaseAPI class and a better description for pagination methods.
Using the new BaseAPI for Record class
Size now is a BaseAPI subclass
Region is a BaseAPI subclass too
Removed __call_api method from Record object
SSHkey class rewritten with BaseAPI as "mother" class.
Removed from SSHKey class the __call_api method: obsolete
Fixed a bug caused by a wrong class name
Created a new method to get all the snapshots ( Images )
Bugfixes
Using the correct class type
Loading objects using the __init__ method of the classes
Implementing the method to get attributes and properties from the args & kwargs in all the __init__ methods
Merge pull request #41 from andrewsomething/fixes
Loading all the data inside a specific dictionary as attributes of the class
Merge branch 'master' of https://github.com/koalalorenzo/python-digitalocean
Starting using a method that will help building correctly the classes
Declaring the attributes inside the Action class.
Implemented the new declaration process inside the Domain class.
New declaration process for attributes inside the Droplet class
Image now has the new attribute declaration inside __init__
Record as Manager has the new declaration method.
Region and Size has the new declaration
Do we want to leave SSHKey alone with the old declaration? naaah?
Loading the details as attributes from the dictionary.
Space means KISS and readability
Fixed a problem when loading elements as dictionary
loading elements as unicode and using the right API-URL path.
Fixed a bug that was not loading correctly the Actions.
Loading the Image/snapshot in a different style
Loading custom headers.
Generic bug fix and improved __check_actions_in_data method.
Created a new method to change the kernel in the droplet.
Created a method to download the list of kernels available.
Created a new Kernel class
Using the Kernel object in the method change_kernel.
Renamed the module to the right name
Merge pull request #44 from avagin/master
The action should return the ID, type and the status when used as string.
using zone_file property instead of live_zone_file.
The domain should return the ID and the name when used as string.
The domain should return the ID and the name when used as string.
The domain should return the ID, the distribution name and the name when used as string.
The kernel should return the name and the version when used as string.
Should the manager return the token when used as string (?)
The domain_name is optional in the Record class.
The record domain should return the name when used as string.
The region should return the name when used as string.
The Size should return the slug name when used as string.
The ssh key should return the ID and the name when used as string.
Using the unicode method as string method.
Merge pull request #45 from avagin/master
Merge pull request #46 from andrewsomething/pagination_fix
Merge pull request #47 from andrewsomething/nyc3
Loading the Image using the "standard" method load()
Created a method to access directly to the "response" of the request.
If the request generated a 204 HTTP status code, then return True, because there should be no content.
The method now returns True as the Droplet when we delete a Domain.
Updated to the version 1.0
Considering the action_ids list only if that is available
Released 1.0.1 after the prerelease
Loading all the actions from a specific API
Fixed problem reported in the issue #51
New minor release.
Mateusz Lapsa-Malawski (1):
added rename and call_api
Michael Bang (2):
Add private networking to droplet.
Remove droplet.private_network variable, since it doesn't comply with project handling of similar variable 'virtio'.
Peter Landry (6):
Add Domain object
Implement Record
Allow for ssh_key_ids and virtio options when creating droplets
Merge branch 'droplet_options'
Accept client_id and api_key on initialization
DigitalOcean api docs are incorrect
Pierre-Olivier Marec (1):
Added ip_address parsing in get_all_droplets
Rich B (1):
Added additional items to the Size class.
Rodrigo Reis (5):
Adding Events, to be able to check tasks status and develop mode support on setup.py
Adding the ip_address field on the Droplet class.
Adding some exception handling and droplet creation example.
Keeping the response.
Version = 0.2.6
dmaust (4):
Pulling SSHKey into package variables.
JSON requirements fix.
requests uses JSON property instead of method.
Merge branch 'master' of github.com:dmaust/python-digitalocean
peterlandry (3):
Use v1 of Digital Ocean API
Use requests >= 2.0.0
typo
samdobson (4):
Fix ImportError in Python3
Use explicit relative imports for consistency
Add dependency on requests for pip installation
Fix typos
sztanko (1):
Added error message handling
-----------------------------------------------------------------------
No new revisions were added by this update.
--
Alioth's /usr/local/bin/git-commit-notice on /srv/git.debian.org/git/python-modules/packages/python-digitalocean.git
More information about the Python-modules-commits
mailing list