[Python-modules-team] Bug#589975: python-traits: isn't compatible with python2.4, please boost up XS-Python-Version for >=2.5

Yaroslav Halchenko debian at onerussian.com
Thu Jul 22 16:40:22 UTC 2010

Package: python-traits
Version: 3.4.0-1
Severity: minor

Just for clarity

I am trying to see if it could be easily backported into lenny, it failed to
build due to import of absolute_import from __future__, which became available
only in 2.5.

With boosted XS-* package does build fine

P.S. Also there is a strong Depends on python-enthoughtbase.
     As far as I could see upon quick look, it just imports:

    from enthought.etsconfig.api import ETSConfig
    # If the ETSConfig package is not available, fake it:
    class ETSConfig ( object ):

So, theoretically it can be used without python-enthoughtbase (I would prefer
trying porting that one to lenny as well for my needs), why not to place
it into Recommends?

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (901, 'unstable'), (900, 'testing'), (300, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages python-traits depends on:
ii  libc6                         2.11.2-2   Embedded GNU C Library: Shared lib
ii  python                        2.6.5-5    An interactive high-level object-o
ii  python-central                0.6.16     register and build utility for Pyt
ii  python-enthoughtbase          3.0.5-1    Core packages for the Enthought To

python-traits recommends no packages.

Versions of packages python-traits suggests:
ii  python-traitsgui              3.4.0-1    Traits-capable windowing framework

-- no debconf information

More information about the Python-modules-team mailing list