[Python-modules-team] Bug#770838: python-numpy: Import fails with ImportError: /usr/lib/libblas.so.3:, undefined symbol: cgemm3m_nn

Patrick Hallen patrick.hallen at rwth-aachen.de
Mon Nov 24 14:31:33 UTC 2014

Package: python-numpy
Version: 1:1.8.2-2
Severity: grave
Justification: renders package unusable

Dear Maintainer,

importing numpy fails with an ImportError exception. The following
backtrace is produced:

>>> import numpy
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/dist-packages/numpy/__init__.py", line 153,
in <module>
    from . import add_newdocs
  File "/usr/lib/python2.7/dist-packages/numpy/add_newdocs.py", line 13,
in <module>
    from numpy.lib import add_newdoc
  File "/usr/lib/python2.7/dist-packages/numpy/lib/__init__.py", line
18, in <module>
    from .polynomial import *
  File "/usr/lib/python2.7/dist-packages/numpy/lib/polynomial.py", line
19, in <module>
    from numpy.linalg import eigvals, lstsq, inv
  File "/usr/lib/python2.7/dist-packages/numpy/linalg/__init__.py", line
50, in <module>
    from .linalg import *
  File "/usr/lib/python2.7/dist-packages/numpy/linalg/linalg.py", line
29, in <module>
    from numpy.linalg import lapack_lite, _umath_linalg
ImportError: /usr/lib/libblas.so.3: undefined symbol: cgemm3m_nn

This is with Python 2.7.8, but I get the same error with Python 3.4.2. I've
also tried installing python-numpy 1:1.9.0~rc1-1 from experimental, which
results in the same error when importing.

This may very well be a bug in libblas3, but I have installed the most
version of libblas3 and the error manifests when importing numpy. I'll
report a bug for libblas3, if you think the problem has to be solved there.

-- System Information:
Debian Release: jessie/sid
  APT prefers testing-updates
  APT policy: (500, 'testing-updates'), (500, 'testing'), (1,
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.16-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages python-numpy depends on:
ii  libblas3 [libblas.so.3]            1.2.20110419-10
ii  libc6                              2.19-13
ii  libgcc1                            1:4.9.1-19
ii  libgfortran3                       4.9.1-19
ii  liblapack3 [liblapack.so.3]        3.5.0-4
ii  libopenblas-base [liblapack.so.3]  0.2.12-1
ii  libquadmath0                       4.9.1-19
ii  python                             2.7.8-2
pn  python2.7:any                      <none>

python-numpy recommends no packages.

Versions of packages python-numpy suggests:
ii  gcc               4:4.9.1-5
ii  gfortran          4:4.9.1-5
ii  python-dev        2.7.8-2
ii  python-nose       1.3.4-1
pn  python-numpy-dbg  <none>
pn  python-numpy-doc  <none>

-- no debconf information

More information about the Python-modules-team mailing list