[Python-modules-team] Bug#770977: Bug#770977: pytest: Fails to build from source

Lennart Sorensen lsorense at csclub.uwaterloo.ca
Tue Nov 25 21:35:52 UTC 2014

On Tue, Nov 25, 2014 at 08:55:05PM +0100, Sebastian Ramacher wrote:
> Control: tags -1 + moreinfo unreproducible
> On 2014-11-25 11:43:32, Lennart Sorensen wrote:
> > Source: pytest
> > Version: 2.6.3-2
> > Severity: serious
> > Justification: fails to build from source
> > 
> > Dear Maintainer,
> > 
> > I was trying to do a rebuild of some of the packages in jessie, and
> > pytest fails the testsuite for python3.4 as far as I can tell.
> > 
> > I used debootstrap --variant=buildd to create a jessie chroot, then
> > installed the build-dep's of pytest and build-essential, and ran
> > dpkg-buildpackage, and the testsuite failed so the package did not build.
> I'm afraid I can't reproduce the issue. I've tried in jessie and sid
> chroot, in i386 and amd64 chroots and even tried building as root as you
> seem to do. But none of my attempts failed. So please tell us more about
> your environment.

Hmm, interesting, I can try and see if I can reproduce it on more systems.

So the machine I was building on is an IBM x3650 with 2 quad core 2.5GHz
xeons.  Kernel is amd64, userspace is i386 wheezy, chroot is i386 jessie
buildd variant.

So I just tried some more tests.

jessie-amd64 on sid-amd64: works
jessie-i386 on sid-amd64: works
jessie-i386 on wheezy-i386(with amd64 kernel): fails
Same chroot copied to a sid machine (so 3.16 kernel instead of 3.2 kernel: works

It would appear that pytest fails on python 3.4.2 when the underlying
kernel is 3.2 for some reason that I can't even imagine what is.

I will try upgrading the kernel on our build machine to the
wheezy-backprot of 3.16 and see if that solves the problem and report

Len Sorensen

More information about the Python-modules-team mailing list