[Python-modules-team] Bug#791590: python-pyquery 1.2.4 incompatible with python-cssselect 0.9.1 it depends on in jessie

Kai Blin kblin at biosustain.dtu.dk
Mon Jul 6 14:14:52 UTC 2015

Package: python-pyquery
Version: 1.2.4-1
Severity: important
Tags: upstream

Dear Maintainer,

when trying to use python-pyquery, my program crashes with
AttributeError: 'XPathExpr' object has no attribute 'add_post_condition'
Apparently (https://github.com/gawel/pyquery/issues/40) this is a known issue
when using cssselect > 0.7.1. However, jessie ships with python-cssselect 0.9.1.

Upstream has released pyquery 1.2.5 to deal with this issue.

Using the most current pyquery and csselect packages from pypi in a virtualenv
allows my program to run successfully.


-- System Information:
Debian Release: 8.1
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.16.0-4-amd64 (SMP w/1 CPU core)
Locale: LANG=en_IE.UTF-8, LC_CTYPE=en_IE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages python-pyquery depends on:
ii  python            2.7.9-1
ii  python-cssselect  0.9.1+git90c72b0-1
ii  python-lxml       3.4.0-1
ii  python-webob      1.4-2

python-pyquery recommends no packages.

python-pyquery suggests no packages.

-- no debconf information

More information about the Python-modules-team mailing list