Bug#877813: reprotest: regression between 0.7.1 and 0.7.2

Ximin Luo infinity0 at debian.org
Mon Oct 9 14:16:00 UTC 2017

gregor herrmann:
> On Thu, 05 Oct 2017 22:59:00 +0000, Ximin Luo wrote:
>> gregor herrmann:
>>> [..]
>>> sudo: Î޷¨½âÎöÖ÷»ú£ºjadzia
>>> tail: Î޷¨´ò¿ª'debian/changelog' ¶ÁȡÊý¾: ȨÏ޲»¹»
>>> dpkg-buildpackage: erreur: fin de debian/changelog a produit une erreur de sortie de type 1
>>> [..]
>>> sudo: impossible de déterminer le nom de l'hôte jadzia
>>> tail: no se puede abrir 'debian/changelog' para lectura: Permiso denegado
>>> dpkg-buildpackage: error: tail of debian/changelog gave error exit status 1
>> tail(1) apparently can't read debian/changelog. 
> Yes, after manually installing fakeroot, which I didn't need to do
> for reprotest <= 0.7.1.
> And the error before "tail: can't open ..." (in Spanish) is still
> "sudo: can't determine hostname ..." (in French).
> I might be wrong, but this still sounds like a problem related to
> sudo to me.
> Full disclosure: I'm not running systems in the Ubuntu-style of "sudo
> all all nopasswd everything <myuser>". And so far both autopkgtest
> and reprotest (which are both using the same schroot chroot, and are
> the only ones, as for building I'm using cowbuilder) just worked.
>> I don't know how you set up your schroot, but reprotest is coded
>> against the sbuild-createchroot stuff. Have you tried using that?
> That's a good question :) And I'm not entirely sure since I did this
> years ago and I only use the schroot chroot for autopkgtest and
> reprotest; but I think it was sbuild-createchroot as well.
>> What command line are you running to get these errors?
> Another good question; I call reprotest from a wrapper script:
> https://anonscm.debian.org/cgit/pkg-perl/packages/pkg-perl-tools.git/tree/examples/check-build#n86
> Which, run under 'sh -x' looks like:
> [..]
As a wild guess, make sure the user that you're running the build as is in the "fuse" group. This is needed for disorderfs. If you don't want to do that, give --vary=-fileordering to reprotest. (This is actually already documented in the README / man page, and disorderfs IIRC should output an error message but that part is cut out of your log).

Otherwise, I'm out of ideas. You need to tell me exactly how to reproduce this issue, including how you created the chroot - otherwise I can't make any progress. I can't possibly guess why tail(1) shouldn't be able to read debian/changelog, apart from the "fuse" issue I just mentioned.

(I don't have NOPASSWD in my sudoers file either.)


GPG: ed25519/56034877E1F87C35
GPG: rsa4096/1318EFAC5FBBDBCE

More information about the Reproducible-builds mailing list