[sane-devel] Umax Astra MX3 scsi/usb + Linux 2.4.7 + sane 1.0.5

Denis Hainsworth Denis Hainsworth <denis@cs.brandeis.edu>
Thu, 2 Aug 2001 12:11:51 -0400

hey folks

having an annoying problem...was wondering if anyone knew of any
debugging tools or info that might help here...

Under Linux 2.4.7 (and 2.2.16) using sane 1.0.5 I have connected to my
Buslogic fast scsi PCI card an external ZIP, CDRW, and Astra scanner.

This combo worked fine on my mac ... decided I'd like to use it all off
of my linux box.  Moved the stuff over ... ended up upgrading to 2.4.7
to get rid of some odd scsi problems when removing devices.  can access
and use everything...

sane/xsane talk to the scanner fine it seems...can turn the lamp on and
off .. however every scan and preview just gets me a blank page.  The
lamp is on the scanner head moves in what seems to be a correct manner.

I have tried rearranging the scsi devices on the chain...same thing.

Is there any way to tell if sane/xsane is getting the data but not
interperting it right?  Sane seems to be detecting the scanner as a 2200
not an MX3.  I think that should be ok but perhaps thats the problem?

So any ideas would be most welcome.



Denis Alan Hainsworth | http://www.cs.brandeis.edu/~denis/  
denis@cs.brandeis.edu | "Life is just one big sad christmas."