[sane-devel] Parallel and saned: GIMP impossible, since no default device found

G. L. `Griz' Inabnit griz@outcast-consultants.redmond.or.us
Tue, 14 Aug 2001 09:35:18 -0700

On Tuesday 14 August 2001 09:12, Gregor Hoffleit wrote:
> I managed to get my parallel port scanner working, and I managed to set
> up saned, so I'm now able to run xsane/xscanimage/scanimage as normal
> user (saned runs as root).
> The problem is that xsane etc. fail to autodetect the scanner that's
> made available through saned on my localhost, i.e. I have to provide
> xsane with the device name on the command line:
>   xsane                      -- fails and quite with "xsane: no devices
>                                 available"
>   xsane net                  -- xsane immediately fails and quits with
>                                 "Failed to open device Invalid argument."
>                                 (no noise from scanner, though)
>   xsane net:localhost        -- noise from scanner, but xsane fails and
>                                 quits with "Failed to open device
> 				'net:localhost': Invalid argument."
>   xsane net:localhost:epson  -- works
> Starting xsane as root, it autodetects the local 'epson' device (since
> it now has permissions to access the pio address):
>   sudo xsane                 -- works, but using the local 'epson' device
>                                 and not 'net:localhost:epson'
> Similar, "scanimage --list-devices" fails to detect anything, but "sudo
> scanimage --list-devices" detects the local scanner device:
>    device `epson:0x378' is a Epson GT-5000 flatbed scanner
> I tried to set "SANE_DEFAULT_DEVICE=net:localhost:epson" in the
> environment, but this seems to have no effect at all.
> The problem is that this makes the scanner unusable with the GIMP, since
> I'm not able to provide the GIMP SANE plugin with a devicename.
> Am I missing something obvious, or is it really impossible to use a
> parallel port scanner with the GIMP due to this limitation ?
>     Gregor


	I found that it was my lines in /etc/inetd.conf that was at fault....

#sane           stream  tcp     nowait  saned.saned     /usr/sbin/saned saned
sane            stream  tcp     nowait  root.root     /usr/sbin/saned saned

	The commented line is the original, the second is the one that worked for 
me. Hope this helps.

> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

                           OutCast Computer Consultants of Central Oregon
                                                 (541) 504-1388
                                            Toll Free (866) 562-7160
                                 Via IRC at;
                                           Via ICQ: UIN 138930

"Failure is not an option...it's bundled with Microsoft"

Hi! I'm a .signature virus! Copy me into your ~/.signature, please!

"Software is like sex. They're both better when they're free!!" - Linus 

"As a computing professional, I believe it would be unethical for me to
advise, recommend, or support the use (save possibly for personal
amusement) of any product that is or depends on any Microsoft product."