[sane-devel] USB scanner troubles

G. L. `Griz' Inabnit griz@outcast-consultants.redmond.or.us
Tue, 11 Dec 2001 18:36:54 -0800


On Tuesday 11 December 2001 08:48 am, Henning Meier-Geinitz wrote:
> Hi,
> On Tue, Dec 11, 2001 at 02:18:41AM -0800, G. L. `Griz' Inabnit wrote:
> > 	Some of this is going to be out of the scope of this mailing list (usb
> > info) but I'm stuck.
> > 	I have a clients machine in my shop who wanted to get away from the M$
> > Kludge so we loaded on Debian. All went lovely until I attempted to setup
> > his Musteck 1200 CU USB scanner. Then I fell on my face (no! not
> > literally)
> You need SANE 1.0.6 for this scanner.

	Damn! Debian (unstable) is running 1.0.5. (sigh) Guess I'm stuck until the
packager gets 1.0.6 packaged up and ready to do. I could build it by hand,
but then I would loose the ability to use   apt    for updates on that
package. Which would require me to babysit this box for eternity. :--)  And
the reason I run linux is because we DON'T have to babysit.
	Though I need to ask....."Why 1.0.6 ?" What was changed/added?
> > 	At connection (plugging the scanner into the usb port) I recieve:
> > hub.c:  USB new device connect on bus1/1, assigned device number 3
> > but there is NO /dev/usb/scanner, /dev/usbscanner, or anything else new.
> > So, I need to ask and find out what I'm doing incorrectly, which part of
> > the docs I missed, etc.
> If you don't use devfs, and your distribution didn't take care of
> this, you must create this file on your own. There is some docu about
> that in /usr/src/linux/Documentation/usb/scanner.txt. Try something
> like:
> mknod /dev/usbscanner0 c 180 48
> After this, sane-find-scanner should be able to detect your scanner.
> > 	I am running 2.4.16 with    /usb/hid    support for the APC UPS Backups
> > 350 (working well too).  I find that in   usbview    I see both devices
> > (scanner/ups), but only the ups is assigned a /dev location. What am I
> > missing???  :--(  And what system info do you folks need?
> Can you see the scanner at /proc/bus/usb/devices ?

	Nope. Not a thing in there. Which has me rather confused too. Do I need to
be running   usbmgr     or something along these lines to 'activate' my USB
devices. (yes, this is off subject and i appologize, but i'm horribly lost
	Okay, just installed   usbmgr    and restarted the machine. I know see at
least the APC UPS in /proc/bus/usb/devices. And under   usbview     I am able
to see both devices (scanner/ups).

	Hmmmm. Interesting. Okay, now I'm THROUGHLY confused. :--)

	I ran the   mknod /dev/usbscanner0 c 180 48    to built the device in
/dev/usb, rebooted the box, and just for giggles I started xsane. It came up,
no complaints, AND scanned perfectly.  This is TOO confusing.  Would the
reason for it not working before be due to the fact that the device didn't
exist and that I'm not running   devfs   ?

> Bye,
>   Henning
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

- --
                           OutCast Computer Consultants of Central Oregon
                                                 (541) 504-1388
                                            Toll Free (866) 562-7160
                                 Via IRC at;
                                           Via ICQ: UIN 138930

"Failure is not an option...it's bundled with Microsoft"

Hi! I'm a .signature virus! Copy me into your ~/.signature, please!

"Software is like sex. They're both better when they're free!!" - Linus

"As a computing professional, I believe it would be unethical for me to
advise, recommend, or support the use (save possibly for personal
amusement) of any product that is or depends on any Microsoft product."