[sane-devel] RFC: New sanei_pv8630 interface

Marcio Luis Teixeira marciot@holly.colostate.edu
Sat, 15 Dec 2001 14:19:16 -0700


Everyone:

In an effort to reduce code duplication, I would like to propose a draft
for a
new sanei interface for the PV8630 chip. The current draft can be found
here:

     http://umax1220u-sane.sourceforge.net/sanei/

The interface is based on the recent work by Frank Zago (with the USB
extension to the UMAX SCSI backend) and earlier work by Adrian Perez
Jorge. The interface supports these commands:

sanei_pv8630_write_byte
sanei_pv8630_read_byte
sanei_pv8630_prep_bulkread
sanei_pv8630_prep_bulkwrite
sanei_pv8630_flush_buffer
sanei_pv8630_bulkwrite
sanei_pv8630_bulkread
sanei_pv8630_xpect_byte
sanei_pv8630_wait_byte

These functions are wrappers around "sanei_usb_control_msg," but they
provide a more type-safe and consistent way of controlling the PV8630
chip.

Please let me know if you have any comments or suggestions.

Marcio Luis Teixeira