[sane-devel] Scanner stopped working

Marcel Pol mpol@gmx.net
Wed, 19 Dec 2001 11:12:26 +0100

On Tue, 18 Dec 2001 20:27:38 -0800
"Richard W. Knight" <rick@rlknight.com> wrote:

> I have a Umax Astra 1200S scanner that has been working perfectly
> Xsane and Gimp for quite some time. The other day I configured USB 
> support on my system and now the scanner won't work. I've tried
> xscanimage and scanimage and each time the program just hangs. No
> messages, nothing. When I run sane-find-scanner I get the following 
> error message...
> sane-find-scanner: error while loading shared libraries: 
> libusb-0.1.so.4: cannot open shared object file: No such file or
> My scanner is SCSI, not USB. I have a USB digital camera that works
> fine and the file mentioned above does exist and is in the right
> as far as I can tell.

I assume Sane was compiled against libusb.
When you run:
ldd /usr/bin/sane-find-scanner
what does it give back?

If your libusb-0.1.so.4 is located in /usr/local/lib, you need to add
/usr/local/lib to /etc/ld.so.conf, and run ldconfig. That should help.

Marcel Pol

Linux 2.4.13-8mdksmp, up 30 days 21:23