[sane-devel] Meaning of --enable-directio in configure and
Tue, 25 Dec 2001 15:19:32 +0100
Henning Meier-Geinitz wrote:
> --enable-directio seems to be used for two different things: First,
> SCSI DMA (from adapter to user memory). This is documented in
> README.linux. Second it's used in umax_pp*, probably for direct
> parport access.
> As these two are quite unrelated I would prefer to change the name of
> the latter to e.g. --enable-outb (or similar) and to document it in
> the README or if it's linux-specific, the README.linux file.
I already contacted Stef regarding this name confusion; I'd suggest to
replace --enable-directio with --enable-scsi-directio and
--enable-parport-directio . The "direct IO" seems to be meaningful for
the parport stuff too.