[sane-devel] medion scanner md 9458

Franky Van Liedekerke liedekef@pandora.be
Sat, 29 Dec 2001 12:22:22 +0100


(system: redhat 7.2, 2.4.9-13 kernel)
I just bought this usb scanner (medion md 9458, an "aldi" scanner) but I
am not able to get it to work. When I do "/cat/proc/usb/devices" I see the
vendor type is 0x05d8 and the product is 0x4002. Now I've searched the
list and this seems to be the lifetec thingie. So I added the following to
my modules.conf: ptions scanner vendor=0x05d8 product=0x4002
and I tried:

/sbin/modprobe scanner vendor=0x05d8 product=0x4002

to force the scanner module to take these arguments, and then I get in the
messages file:

usb.c: registered new driver usbscanner
scanner.c: probe_scanner: User specified USB scanner -- Vendor:Product -
5d8:4002 scanner.c: probe_scanner: Only two or three endpoints supported.
scanner.c: USB Scanner support registered.

/sbin/lsmod shows:
scanner                 7808   0  (unused)
usb-uhci               20708   0  (unused)
usbcore                49920   0  [scanner usb-uhci]

And still sane does not see my scanner (tried both sane-find-scanner and
scanimage -L) ... Is the remark "Only two or three endpoints supported" an
error? Now I wonder how I can get my scanner to work? Or how I can see
that at least my system recognizes the scanner?