[sane-devel] Re: sane 1.0.5 with xsane 0.76

Martin martin.hf@gmx.de
Wed, 25 Jul 2001 01:51:56 +0200

Hallo Oliver, 
Hallo Henning

sorry for answering that late, but sometimes I have to work. ;-)

Am Donnerstag, 19. Juli 2001 23:24 schrieb Oliver Rauch:
> Martin Heggemann wrote:
> > When I do a preview-scan (gray or color; lineart is o.k.) via
> > network with my Mustek MFS-12000SP, xsane 0.76 crashes every time
> > the preview scan is completed (segmentation fault).
> This should be solved in xsane-0.78.

I just upgraded to xsane-0.79 and there is no seg-fault after a 
preview-scan any more.
Everything seems pretty fine!

> > PS: I also tried to compile xsane 0.77 and 0.78 but both complain
> > about not finding the library "glibconfig.h":
> is glibconfig.h on your system?

It is located in /usr/lib/glib/include/glibconfig.h
In the file it says: "This is a generated file..." it was created on 
16.02.2000. So it should have been there, when I tried to compile xsane 
last week. (I didn't install anything in that period of time!)

Am Mittwoch, 18. Juli 2001 20:32 schrieb Henning Meier-Geinitz:
> The mustek backend in SANE 1.0.5 had some bugs concerning SCSI and
> Linux 2.4.x so you may want to update the backend to version 1.0-111.

The server with the scanner attached runs on Kernel 2.2.14, so that 
shouldn't be a problem.

> Does local scanning have the same problem?

My server runs in text-mode, so I can't do any preview-scan with xsane 
on it.

Danke fuer Eure Hilfe