[sane-devel] Sane on Linux Sparc...

Tomislav Renic renic@Envirogenca.com
Fri, 21 Sep 2001 15:45:02 -0400

Sorry about the lack of details.  I realized after I sent the email that I
should have been a bit more explicit with my system details.  Here's what
I've got:

Sun Ultra 10 with 300 MHz Ultrasparc IIi
Adaptec AHA2940UW Controller at SCSI-ID=7
UMAX S6E scanner on SCSI-ID=5
Debian Linux with kernel 2.4.7 using loadable modules for aha7xxx.o and sg.o
sane version 1.0.5 (I tried both the debian precompiled packages and rolling
my own...same problem)
Shared libraries are indeed supported
I could use xscanimage if I sane could recognize the scanner.

Here's the debug output from the mustek backend:
debian:~# SANE_DEBUG_MUSTEK=4 scanimage -L
[sanei_debug] Setting debug level of mustek to 4.
[mustek] SANE mustek backend version 1.0 build 107 from sane-backends-1.0.5
[mustek] sane_init: reading config file `mustek.conf'
[mustek] sane_init: config file line 4: strip-height set to 1 inches
[mustek] sane_init: config file line 10: trying to attach `scsi MUSTEK *
[mustek] sane_init: config file line 14: option lineart-fix ignored, was set
before any device name
[mustek] sane_init: config file line 16: trying to attach `scsi SCANNER'
[mustek] sane_init: config file line 20: option lineart-fix ignored, was set
before any device name
[mustek] sane_init: config file line 22: trying to attach `/dev/scanner'
[mustek] attach: trying device /dev/scanner
[mustek] dev_open: /dev/scanner is a SCSI device
[mustek] dev_open: wanted 8 kbytes, got 8 kbytes buffer
[mustek] attach: inquiry for device /dev/scanner failed (Error during device
[mustek] sane_init: config file line 26: option lineart-fix ignored, was set
before any device name
[mustek] sane_get_devices: 0 devices

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[mustek] sane_exit

Thanks for the help and feel free to ask anything you want...


-----Original Message-----
From: Henning Meier-Geinitz [mailto:henning@meier-geinitz.de]
Sent: Friday, September 21, 2001 3:12 PM
To: 'sane-devel@www.mostang.com'
Subject: Re: [sane-devel] Sane on Linux Sparc...


On Fri, Sep 21, 2001 at 09:13:26AM -0400, Tomislav Renic wrote:
> I was wondering if anybody else out there has tried running sane under
> on an Ultra Sparc.

There hasn't been any report at all until now as far as I know. Could
you please give some more details: SANE version, Linux version,
compiler + version, are shared libraries supported and does dynamic
loading (over the dll backend) work, can you use xscanimage? That's
for our supported platforms page:

> The software compiles without a problem, but it seems that it cannot
> recognize my scanner as such.  Here's the output of find-scanner:
> sane-find-scanner: searching for scanners:
> sane-find-scanner: checking /dev/scanner... open ok
> sane-find-scanner: found disk "  " at device /dev/scanner

It looks like the response from the scanner couldn't be understood by
sanei_scsi.c. I don't know too much about this code, maybe there are
endian or 32/64 bit issues?

Can you please try to run

SANE_DEBUG_MUSTEK=4 scanimage -L

And send the output to the list? The mustek backend contains an
inquiry output, so we should be able to see what's happening.

Sane-devel mailing list