[sane-devel] mustek_pp-11.alpha with gphoto2 problem

Till Kamppeter till.kamppeter@gmx.net
Fri, 23 Aug 2002 17:16:40 +0200


You must install the header package of gphoto2 before building the 
package, probably it works with one of the following commands:

    apt-get install gphoto2-devel
    apt-get install gphoto2-dev
    apt-get install libgphoto2-devel

This package contains the "gphoto2-config" program and all other files 
needed to compile a program using the gphoto2 library.

    Till


Andrea Rossetti wrote:
>>Hi,
>>
>>the debian package does _not_ include the gphoto2 backend by default,
>>you have to modify the debian/rules file to configure the gphoto2
>>backend, i.e. include the option --with-gphoto2 in the configure call.
>>
>>(Il package Debian non include di default il backend di gphoto2,
>>devi modificare i debian/rules file per configurare il backend di
>>gphoto2. Esempio: includi l'opzione --with-gphoto2 nel ./configure)
>>
>>
> 
> 
> Hi,
> I've modified the debian/rules script as the following
> -------------------------------------------------------------------------
> ...
>          ./configure --prefix=$(prefix) --sysconfdir=/etc \
>                  --datadir='$$(prefix)/share/sane' \
>                  --mandir='$$(prefix)/share/man' \
>                  --with-gphoto2 # <--------------------------- this is my
> inserted line
> ...
> -------------------------------------------------------------------------
> 
> But unfortunately it's not true! SIGH!!!
> 
> I have done the following:
> 
> cd sane-backends-1.0.7/
> debian/rules binary &> err
> 
> to make the deb packace derirecting the standard output and the standard
> error to "err" file (that I've included).
> During the execution of the configure script the script return
> -------------------------------------------------------
> ...
> checking for gphoto2-config... no
> ./configure: line 1: gphoto2-config: command not found
> ./configure: line 1: gphoto2-config: command not found
> 
> Sorry, can't use GPHOTO2
> GPHOTO2 APIs have been changing rapidly. Only
> the current version from CVS is likely to work.
> ...
> -------------------------------------------------------
> 
> Please help me! (:-)
> 
> Andrea.