[sane-devel] Red Hat 8.0 and CanonScan N656U

Henning Meier-Geinitz henning@meier-geinitz.de
Sun, 1 Dec 2002 19:48:25 +0100


On Sun, Dec 01, 2002 at 07:29:29PM +0100, Maurizio Tiecher wrote:
> I have commanded: #make all, # make install, #make load. 

"make load" loads the parallel port kernel scanner module. Don't do
that. You don't have a parallel port scanner.

> I have tried the command: #sane-find-scanner has had the response:
> find USB scanner (vendor= 0x04a9 [Canon] product= 0x2206 [CanonScan]) at /dev/usb/ scanner0
> find USB scanner (vendor= 0x04a9 [Canon] product= 0x2206 [CanonScan] ) at libusb: 001: 003

Ok, looks good.

> # scanimage -L:
> No scanner were identified.

 See man sane-plustek. Edit plustek.conf if necessary.

> bin# rmmod scanner modprobe scanner vendor= 0x04a9 product= 0x2206

Don't put everything in one line! "rmmod scanner" is for unloading the
scanner module, "modprobe scanner ..." is for loading it again with
options set. And don't put spaces aftert the "=". Anyway, as
sane-find-scanner has detected your scanner there is no need for this

> I have tried to alter the line plustek.conf with Emacs inserting the
> vendor and product of the Canon scanner but.

Show us what you did. Also show us the output of

SANE_DEBUG_PLUSTEK=255 scanimage -L

> I have removed the # in the line dll.conf in front of the lines for
> Canon scanner, but it has not changed nothing. 

It's supported by the Plustek backend, so you must make sure, that
"plustek" is in dll.conf.