[sane-devel] Unable to access minor data

Henning Meier-Geinitz henning@meier-geinitz.de
Tue, 3 Dec 2002 21:26:51 +0100

[ I'm cc'ing the list again because this may be of interest for other
users, too]

On Tue, Dec 03, 2002 at 08:15:13PM +0000, Alexis wrote:
> > It's not a problem of SANE but of the kernel scanner driver.
> >
> Okay I have recompiled the kernel so that both usb support and scanner 
> support are both modules (this approach fixed a sound problem once), and 
> sane-find-scanner now gives me the 
> checking /somedevice/ failed to open (invalid argument) 
> error that I have had in the past, so it is able to find the device files, 
> just not the scanner...

So it still doesn't find the scanner. What about the other things I
told you? I mean loading the scanner module with options and looking
at /proc/bus/devices?

> Just tried scanimage -L.  It gets as far as ScLoader okay now, and then 
> segfaults.
> Is this still a kernel problem, or something else?

I'm not a viceo expert but I'm pretty sure that you won't have success
until sane-find-scanner lists your scanner. That's because if it's not
found by sane-find-scanner it's usually not found by the kernel either
and so xan't be used by the viceo backend.