[sane-devel] Problem with sane-1.0.9, PPC, ScanJet 4C

Keith Clayton keith@claytons.org
07 Dec 2002 08:57:29 -0800

Content-Type: text/plain
Content-Transfer-Encoding: quoted-printable

Hi all,

I just recently was given an HP scanjet 4c and I'm trying to get it
working with my system.  So far no luck.  I guess most obivious is that
it was known to be working on Win98 before I got it .. so

I'm running Linux 2.4.19 on a PPC machine.  Compiled SANE-1.0.9 from
source using gcc-3.2.1 . . compilation was fine, uneventful.

SCSI generic is compiled into the kernel and the scanner is recognized
at boot time as /dev/sgc.  I have an internal scsi cd-rw drive that is
working fine with cdrecord (uses scsi-generic) and an old external
syquest which are both working fine also so SCSI looks ok.

Here's my output from cat /proc/scsi/scsi

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: YAMAHA   Model: CRW4416S         Rev: 1.0h
  Type:   CD-ROM                           ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: SyQuest  Model: EZ135S           Rev: 1_12
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 02 Lun: 00
  Vendor: HP       Model: C2520A           Rev: 3503
  Type:   Processor                        ANSI SCSI revision: 02

I've created a symlink from /dev/scanner to /dev/sgc and when I run
sane-find-scanner, it sees an HP C2520A at /dev/sgc, /dev/sg2 and
/dev/scanner.  So far so good.

When I run scanimage -L however, no scanners are found.  Note: for
testing right now, I'm running as root and I checked the permissions of
/dev/sgc just to be sure (0660)

I searched the mail archives and couldn't find any recent issues with
PPC and the HP backend so I went to the faq.  Found the HP faq and
looked at that.  Mentioned device i/o errors with certain scsi cards and
mentioned upgrading the HP backend to v1.0.1

So, first I ran SANE_DEBUG_HP=3D255 scanimage -L with the old backend
(v0.96 IIRC) and captured the output then I upgraded to v1.0.1.=20
Recompiled just find but

That one dumped core on me with an error

scanimage: hp-option.c:3501: sanei_hp_optset_scanmode: Assertion `mode'

when I ran scanimage -L. =20

I ran SANE_DEBUG_HP=3D255 scanimage -L with that backend and captured that
output as well.

With each backend, it appears that sane and my HP4C are talking but that
SANE is getting unexpected responeses (endian problems?)

So, I'm not sure where to go with this.  I don't know myself what the
communication "should" look like.

I'd be happy to post my debug output though it's rather lengthy.  I
figured it'd be better to send it off list to anyone who could make
sense of it.

Thanks for any help anyone can give


Keith Clayton

"If you don't trust me with your source code,
            why should I trust you with my computer?"

GPG key: http://www.claytons.org/kclayton/keith_pub_key_2002_0203.html     =
         http://wwwkeys.us.pgp.net                            =20
GPG fingerprint: C181 38BF 31BC B518 312B  EB6F 1AC8 288B 54D4 2481

Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

Version: GnuPG v1.2.0 (GNU/Linux)