[sane-devel] Failing to scan over network

Brent Hasty blueeagle1@crosswinds.net
Mon, 16 Dec 2002 11:34:38 -0800

On Saturday 16 November 2002 03:05 am, Henning Meier-Geinitz wrote:
your tips hear were helpfull and got me alot closer to having network sca=
ability.  acessing scanimage on localhost is confirmed to work
so I next issued this command on a computer without scanner "Client" I am=
trying to be able to scan on:

[root@h2o sane.d]# SANE_DEBUG_NET=3D255 scanimage -L
[sanei_debug] Setting debug level of net to 255.
[net] sane_init: authorize =3D 0x804a8e0, version_code =3D 0xbffff178
[net] sane_init: SANE net backend version 1.0.9 from sane-backends-1.0.8
[net] sane_init: Client has little endian byte order
[net] sane_init: determining sane service port
[net] sane_init: could not find `sane' service (No such file or directory=
using default port 6566
[net] sane_init: searching for config file
[net] sane_init: trying to add
[net] add_device: adding backend
[net] add_device: backend added
[net] sane_init: done reading config
[net] sane_init: evaluating environment variable SANE_NET_HOSTS
[net] sane_init: done
[net] sane_get_devices: local_only =3D 0
[net] connect_dev: trying to connect to
[net] connect_dev: connection succeeded
[net] connect_dev: sanei_w_init
[net] connect_dev: net_init (user=3Droot, local version=3D1.0.3)
[net] connect_dev: freeing init reply (status=3DInvalid argument, remote=20
[net] connect_dev: access to denied
[net] connect_dev: closing connection to
[net] sane_get_devices: ignoring failure to connect to
[net] sane_get_devices: finished (0 devices)

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[net] sane_exit: exiting
[net] sane_exit: closing dev 0x8054450, ctl=3D-1
[net] sane_exit: finished.
[root@h2o sane.d]#

It looks very near working only in the very end while trying to acess the=
device did things go wrong.

The server with the hp G85 attached does not have the same user list as t=
terminal server with the clients attached. Do I need to setup a user prof=
for each user on the server who will be acessing scanning services via sa=

> Hi,
> On Sat, Nov 16, 2002 at 12:16:19AM +0100, Steven Lowette wrote:
> > If I run saned as a daemon from inetd or xinetd, with full debug outp=
> What do you mean by ""with full debug output"? If you set options -d
> or -s you can't run saned from inetd or xinetd, that's for manual
> start only.
> > I
> > get in my /var/log/syslog after a remote scanimage -L:
> >
> > Nov  7 12:06:26 igor saned[3704]: main: starting debug mode (level 12=
> > Nov  7 12:06:27 igor saned[3704]: main: trying to get port for servic=
> > `sane' (getservbyname)
> > Nov  7 12:06:30 igor saned[3704]: main: port is 6566
> > Nov  7 12:06:30 igor saned[3704]: main: socket ()
> > Nov  7 12:06:30 igor saned[3704]: main: setsockopt ()
> > Nov  7 12:06:30 igor saned[3704]: main: bind ()
> > Nov  7 12:06:30 igor saned[3704]: main: bind failed: Address already =
> > use
> Well, the address is already in use :-) Explanation: xinetd binds to
> port 6566 and starts saned, if a request comes in. The communication
> between saned and xinetd uses stdin and out.
> However, if you run saned -d from xinetd, saned will try to open port
> 6566. Bang! That one is already opened by xinetd.
> So remove "-d" from saned in xinetd.conf.
> > If I run manually saned -d128 on the command line, the same
> > remote 'scanimage -L' works. However, issuing 'scanimage hp:/dev/scan=
> > starts and finishes a scan, but yields an IO-error after some time (w=
> > no image output on the scanimage side):
> >
> > sane_start: Error during device I/O
> scanimage hp:/dev/scanner can't work. First, the option for setting
> the device is -d. Second, you want to scan over the net, so the
> command would be e.g.:
> scanimage -d net:hostname:hp:/dev/scanner
> But I don't think that's the real problem.
> What's the debug output when you run saned -d128?
> > I have iptables running on the machine with the scanner, but that's o=
> Sure? You need port 6566 and a data port. The data port is selected
> by the system running saned. It can be any port > 1024.
> > With the filters disabled, the problem remains. The computer with the
> > scanner is very slow, but as the local scanning works, I guess this i=
> > neither an issue.
> Try local network scanning first. On the computer with the scanner,
> add "localhost" to net.conf. Try scanning with:
> scanimage -d net:localhost:hp:/dev/scanner
> No errors? Then it's either a problem with your filters or the second
> computer.
> To get more debugging on the client:
> SANE_DEBUG_NET=3D255 scanimage -L
> Bye,
>   Henning
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

 11:30am  up 4 days, 11:59,  8 users,  load average: 0.00, 0.01, 0.00