[sane-devel] scanimage problem / sane 1.0.8 / Epson / Solaris 8 (x86)

Ed Randall ed.randall@ingenotech.com
Fri, 28 Jun 2002 08:18:51 +0100

Bruce Riddle wrote:
> > >
> OK I'm on Solaris X86 and Sane 1.08 as well, I had to diddle to get it compiled
> as well but I have it working with my old HP Scanjet 4p.
> Wasn't satisfied with that scanner and it was too slow so my new Epson 1640SU
> arrived today.
> I modified /kernel/drv/sgen.conf changed HP to EPSON.
> Again I had to use PROCESSOR and not SCANNER or sgen would not load a driver.

Yep I had to do that too, also I have a link 
"/dev/scanner -> /dev/scsi/processor/...whatever the sgen device is..."
(machine is switched off at the moment so can't check easily)
I can't remember whether I created this or the kernel did that
automagically for me.  I suspect it was me.  Sorry I'm so vague,
2 young children seem to have dulled my brain somehow ;-)

> device-type-config-list="processor";
> inquiry-config-list=    "EPSON"
> name="sgen" class="scsi" target=5 lun=0;

Yep.  I think you only HAVE to have one of device-type-config-list
and inquiry-config-list, having both does no harm though.

> Using xscanimage works unless I choose color.
> Binary and Gray seem to work just fine even at 3200dpi.

I've not tried xscanimage, just scanimage and xsane.

> If I choose color.
> "ERROR during read. Error during device I/O."
> If I power cycle the scanner and try color or gray it
> works.  I'm not locked up at all. I don't have to restart
> anything other than the scanner.

Sounds almost exactly like mine except once I have had that
I/O error I have to quit and restart xsane, and it would never
work.  Sometimes I got SIGSEGV too.

> I want to get the SCSI side of the house going before tackling the USB.
> Do you think dropping the buffer back to 64kb will fix any of this?

I does seem to have worked for me ;-)
I can now scan reliably in xsane again without problems, just like
I used to using the Schilly scg driver under 2.6