[sane-devel] SANE 1.0.5 -> 1.0.8 *help*! (long)

Journeyman jman@masternet.it
Sat, 29 Jun 2002 02:55:08 +0200


My name is Antonio and I joined this ml because I have a problem I cannot solve and which is driving me nuts. Nobody at the moment could help me (ng, support, ...), so pls excuse me if I joined this ml only for my own "purposes".

I have a MDK 8.1 which features by default SANE 1.0.5, therefore the following rpm are installed:


As a matter of facts I have a Mustek 1200CU Plus (usb). I see that I need SANE 1.0.8 in order to run it. OK, I download these files:


I compile and install in /usr/local the new backends, configure a few files and the scanner works. Great.
Now I cannot install the other 3 files because a) the 2 rpms depends on the elder version of SANE, therefore I should be obliged to reinstall an obsolete version of SANE (in /usr if I'm not wrong...) and b) the new frontends won't compile because the libraries are missing ... a vicious circle.

It 3 a.m., I'm a stubborn newbie, I spent 2 days figuring out what to do to solve these version conflicts ... I really don't know what to do anymore, I'm sorry I may have missed some error msgs to give you. I suppose that if I had the libsane and libsane-devel libraries NOT in rpm format I could install them without pulling back the 1.0.5 version of SANE. I'd like to start from scratch installing everything but I can't find the UNINSTALL cmd of the 1.0.8 backends ... a mess.

Pls any help will be appreciated .... 
I know that YOU are reading this, *you* that have installed a 1.0.8 over a 1.0.5 PLS tell me how you did the trick!! Thanks.

"Never have anything in your life that you cannot walk away
from in ten seconds if you feel the heat around the corner."
(Robert de Niro, Heat)
Journeyman of 666, Inc.
Sorso su Ranocchia Triple, mod. Y2K