[sane-devel] New Epson Perfection 1650 scanner

David Lerner dslerner@ieee.org
Sun, 15 Sep 2002 22:52:16 -0400

Thanks to all who helped me to get my 1650 scanner working. I had 
wanted to report what what I did that fixed it, but I seem to be 
unable to break the functionality by backing out the fixes that I 

Suggestions that I applied tha seemed helpfull were:

adding "options scanner vendor=0x4b8 product=0x110" to 

Commenting out the scsi line in /etc/sane.d/epson.conf (I had 
already enabled the usb line).

Editing /etc/hotplug/usb.distmap so that one of the scanner entries 
matches the vendor and product identification of the 1650.

These changes allowed scanimage to work, identifying the 1650 as"
device `epson:/dev/usb/scanner0' is a Epson GT-8200 flatbed scanner

XSane was not able to find the scanner, so I tried running yast2 (a 
configuration utility in the SuSE distribution). This identified the 
scanner and offered to configure it. XSane subsequently functioned 
of, but I was left to wonder how that was accomplished. I believe 
that the trick was to create /dev/usbscanner and change the 
epson.conf file to reference it instead of /dev/usb/scanner0. Yast2 
aslo modified /etc/sane.d/dll.conf to comment out all backends 
except epson.

A subsequent attempt to use the scanner with Red Hat 7.3 also worked 
with scanimage but failed with XSane. This was solved by downloading 
and installing xsane-0.88.

Thanks again for the great support.