[sane-devel] Mustek Scanmagic 9636S not works

Henning Meier-Geinitz henning@meier-geinitz.de
Sat, 5 Apr 2003 16:46:17 +0200


please respond to the list, not to me. Maybe other people have more
ideas about your problem.

On Sat, Apr 05, 2003 at 01:58:48PM +0000, José López Ruiz wrote:
> >>init_module: No such device.
> >>
>    Hint: insmod errors can be caused by incorrect module parameters, 
> including invalid IO or IRQ parameters.
>    insmod /lib/modules/2.4.14/kernel/drivers/scsi/g_NCR5380.o failed.
>    insmod g_NCR5380 failed.
> >Well, I don't have clairvoyance :-) What are the error messages on the
> >command line and in /var/log/syslog?

Looks like wrong parameters. All my cards worked with the default
settings but some people reported that they had to change i/o
settings. Maybe a different card uses the same i/o range?

>    With other I/O not works. The same error.

Card defective or not plugged in correctly? Try a different ISA slot. 

> Apr  5 13:35:23 anastasia kernel: SCSI subsystem driver Revision: 1.00
> Apr  5 13:35:23 anastasia kernel: scsi0 : SCSI host adapter emulation for IDE ATAPI devices
> Apr  5 13:35:23 anastasia kernel:   Vendor: RICOH     Model: CD-R/RW MP7083A   Rev: 1.10
> Apr  5 13:35:23 anastasia kernel:   Type:   CD-ROM                             ANSI SCSI revision: 02
> Apr  5 13:35:23 anastasia kernel: Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
> Apr  5 13:35:23 anastasia kernel: sr0: scsi3-mmc drive: 32x/32x writer cd/rw xa/form2 cdda tray
> Apr  5 13:35:23 anastasia kernel: Uniform CD-ROM driver Revision: 3.12

I'm not sure if this is a problem here but there were reports about
the SCSI emultation for CDROMS making trouble with detection of real
SCSI devices. I would be surprised if it stops the detection of SCSI
controllers but you'd better try without idescsi.

> Apr 5 13:56:08 anastasia pppd[374]: sent [PAP AuthReq id=0x1
> user="******" password=<hidden>]

Thanks for your user id :-) Be carefull with sending complete logs to
other people without checking what you send. The opassword was hidden
in this case but that may be different with other logs.