[sane-devel] Gradually increasing scan times

Peter Kirchgessner peter@kirchgessner.net
Fri, 11 Apr 2003 07:22:20 +0200


if you believe it is a memory problem, you can run xosview to watch the 
memory use during scan.
But it really may be a hardware problem. The scanner is warming up the 
lamp and is waiting until the light stabilizes. And maybe you have a 
version of the hp-backend that switches off the lamp after each scan. 
The current backend will not do that. This could also speed up the 
following scans.



Karl O. Pinc schrieb:
> Hi,
> My question is probably not directly related to sane,
> although who knows?
> I've got a HP Scanjet model 6100C (product C2520A) attached
> to a Adaptec 1524 scsi card.  Right now I'm running the
> latest RedHat 7.2:
> xsane-0.82-3.1
> sane-backends-devel-1.0.5-4.1
> sane-backends-1.0.5-4.1
> xsane-gimp-0.82-3.1
> sane-frontends-1.0.5-2
> Linux mofo.meme.com 2.4.18-27.7.xsmp #1 SMP Fri Mar 14 05:52:30 EST 2003 
> i686 unknown
> One upon a time, it worked.  (I recall somewhere in the early .60
> xsane releases, maybe.)  As time has gone by it's taken longer and
> longer to scan.  The delay is 'between' the little noises the scanner
> makes.  Right away there's a noise (where the scanner resets?)  Then a
> pause.  Then another nose a bip-bop (where the scan head zeros?)  Then
> a noise when it first scans and then moves the scan head back to the
> resting position.  The pause between the noises gets longer and
> longer.  After installing the latest kernel upgrade it now takes about
> 10 minutes or so to go through the whole cycle and, this is new, the
> resultant image is black.
> I don't use the scanner much at all, and leave the machine up for
> months.  I used to be able to rmmod the aha152x module and then
> modprobe it and the delays would go away.  I figured there was a
> memory leak (mozilla/galeon seems to have one) or something somewhere.
> Now, the scanner is unusable.  (And it's tax time.  :)
> FWIW, for quite a while I've had to start xsane twice.
> The first time it always says
> that no device is found.  IIRC, maybe, that when I first got the
> scanner working I didn't have this problem.  The scsi II cable is a
> little long, going from the floor to the desk but....  There are also
> 2 other devices attached to the same scsi chain, and they seem to
> work.  There's no messages in dmesg or /var/log/messages.  (Except for
> the bus reset related stuff from my module reloading.)
> What's the best way to approach fixing this problem?  I once had faith
> that HP devices would continue to work, but their printers now seem to
> break regularly.  Is this a hardware problem?  The lamp is old and
> weak or a sensor needs the dust removed?  It doesn't have that sort of
> feel.  (It has the feel of scsi hell.)  I've tried disconnecting some
> of the other devices on the bus (and adding an active terminator) to no 
> effect.
> (I've just downloaded the RH 9 sane and xsane source rpms, but I don't
> know if they'll compile without a lot of hassle and I'm not confident
> that will fix the problem.)
> hp.conf is:
> scsi HP C2520A * * * * *
> modules.conf is:
> alias scsi_hostadapter aic7xxx
> alias scsi1 aha152x
> options aha152x io=0x340, irq=10, sync=0
> Here's some relevant /var/log/messages output:
> Apr 10 21:27:34 mofo su(pam_unix)[26943]: session closed for user kop
> Apr 10 21:27:50 mofo kernel: scsi : 1 host left.
> Apr 10 21:28:34 mofo kernel: aha152x: BIOS test: passed, detected 1 
> controller(s)
> Apr 10 21:28:34 mofo kernel: aha152x: resetting bus...
> Apr 10 21:28:35 mofo kernel: aha152x1: vital data: rev=1, io=0x340 
> (0x340/0x340), irq=10, scsiid=7, reconnect=enabled, parity=enabled, 
> synchronous=disabled, delay=1000, extended translation=disabled
> Apr 10 21:28:35 mofo kernel: aha152x1: trying software interrupt, ok.
> Apr 10 21:28:35 mofo kernel: scsi1 : Adaptec 152x SCSI driver; 
> $Revision: 2.4 $
> Apr 10 21:28:36 mofo kernel:   Vendor: HP        Model: 
> C2520A            Rev: 3644
> Apr 10 21:28:36 mofo kernel:   Type:   
> Processor                          ANSI SCSI revision: 02
> Apr 10 21:28:36 mofo kernel:   Vendor: YAMAHA    Model: 
> CRW4260           Rev: 1.0q
> Apr 10 21:28:36 mofo kernel:   Type:   
> CD-ROM                             ANSI SCSI revision: 02
> Apr 10 21:28:36 mofo kernel: Attached scsi generic sg3 at scsi1, channel 
> 0, id 4, lun 0,  type 3
> Thanks.
> Karl <kop@meme.com>
> Free Software:  "You don't pay back, you pay forward."
>                  -- Robert A. Heinlein
> _______________________________________________
> Sane-devel mailing list
> Sane-devel@www.mostang.com
> http://www.mostang.com/mailman/listinfo/sane-devel

Peter Kirchgessner