[sane-devel] Xsane go.... -no go.... "Bugger!"

Frank Frank@snapafun.co.nz
Mon, 4 Aug 2003 17:01:54 +1200

On Sun, 03 Aug 2003 11:51 am, Henning Meier-Geinitz wrote:
> Hi,
> On Mon, Aug 04, 2003 at 12:48:07AM +1200, Frank wrote:
> > > Which kernel version do you use? What do you mean by Linux prefers
> > > non-self power mode? Error messages?
> >
> > Kernel version : 2.4.21 I believe, forgotten syntax to see.
> Ok, that should be new enough. There are some more USB fixes in
> 2.4.22-pre9,  so if nothing else helps, you could try that one.
> > Self mode refers to the hub using it's own power source. ie. It is
> > plugged into the wall socket directly for it's power and not reliant on
> > my 'box' supplying it with it's power. [Either option is available with
> > this device.]

> I know :-) What I wanted to know is, how do you know that "linux
> prefers the bus power mode"? Does is just not work with external
> power?

The system 'hung' when I attempted to access the memory stick but continued on 
its way when I switched off the 'Self' mode.

> > "scanimage -L".
> > device `v4l:/dev/video0' is a Noname STV0680 virtual device

> That's your camera. If you don't want to use it with SANE, you can
> disable it by commenting out "v4l" in /etc/sane.d/dll.conf.

OK. Tried that and got back to 'no devices found' NB. when xsane was running 
[and previewing me through my PocketCam] I went to preferences and selected 
'Load devices'. There it saw my scanner but the resultant action when I 
selected it had me back out.

> However, that doesn't explain why your scanner isn't listed. Check
> that /etc/sane.d/dll.conf contains "snapscan" (in that exact spelling).

It is there as 'snapscan' all lower case [without the quotes of course]

> > Aug  4 00:24:54 localhost kernel: scanner.c: open_scanner(0): Scanner
> > device is already open
> That means when you run "scanimage -L" another program had already
> opened the scanner. YOu can't open it twice at the same time. Maybe
> there was xsane or another fronetend running? Maybe it crashed but is
> still blocking /dev/usb/scanner0 for some reason? Check ps -ax.

Er.... nothing obvious to me here. What ought I be looking for?

> > > SANE_DEBUG_SNAPSCAN=255 scanimage >/tmp/image.pnm 2>log
> >
> > One very blank file? Size 0.
> That's because your default device seems to be the camera. Try
> SANE_DEBUG_SNAPSCAN=255 scanimage -d snapscan >/tmp/image.pnm 2>log

I couldn't get any results from this issue so dropped the >/tmp... etc part 
and got:

# SANE_DEBUG_SNAPSCAN=255 scanimage -d snapscan
[sanei_debug] Setting debug level of snapscan to 255.
[snapscan] sane_snapscan_init
[snapscan] sane_snapscan_init: Snapscan backend version 1.4.22
[snapscan] add_usb_device(libusb:001:003)
[snapscan] add_usb_device: Detected (kind of) an USB device
[snapscan] snapscani_usb_open(libusb:001:003)
[snapscan] add_usb_device: error opening device libusb:001:003: Device busy
[snapscan] sane_snapscan_open (, 0xbffff484)
[snapscan] find_device
[snapscan] sane_snapscan_open: device "" not in current device list.
scanimage: open of device snapscan failed: Invalid argument
[snapscan] sane_snapscan_exit

Looks like heaps of trouble for me here?

> to select the scanner.
> > I do not believe that there is anything wrong with sane, it's just that I
> > needed to start somewhere relative to my problems.
> Well, but maybe the error messages help to find out what's going on.
> > I attempted to reset the preferences for xsane thinking that the base
> > settings had been changed with the new hub connection and reboot with the
> > new hub.
> >
> > I get, and am leaving undone till later, the following response;
> >
> > File "/home/frank/.sane/Acer.FlatbedScanner13.drc" has been created for
> > device "Acer.FlatbedScanner13", you want to use it for device
> > "Noname:STV0680" , this may cause problems!
> You tried to load /home/frank/.sane/Acer.FlatbedScanner13.drc (the
> config for your flatbed scanner) for your camera. So the warning is
> correct.

Got that and it fits with my "NB" above. I just wonder if there is a means 
within Xsane to actually select the preferred device?


Big or small, any challenge requires the same commitment to resolve.