[sane-devel] Epson Perfection 1650 w/ RedHat 8.0

Alexander Jolk alexj@buf.com
Wed, 17 Dec 2003 17:59:49 +0100


Epson Perfection 1650 (USB) on Linux RedHat 8.0.  The scanner worked
fine some time ago, now it doesn't.  The kernel and sane-backends may
have been updated since it last worked, but I cannot get things to work
with older versions either.  Currently trying: RedHat's kernel
2.4.20-20.8, and RedHat's sane-backends-1.0.8-5.2.

The scanner appears in `lsusb', the kernel `scanner.o' module is loaded

# sane-find-scanner 
# Note that sane-find-scanner will find any scanner that is connected
# to a SCSI bus and some scanners that are connected to the Universal
# Serial Bus (USB) depending on your OS. It will even find scanners
# that are not supported at all by SANE. It won't find a scanner that
# is connected to a parallel or proprietary port.

sane-find-scanner: found USB scanner (vendor = 0x04b8, product = 0x0110)
at device /dev/usb/scanner0
# scanimage -L

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

I have commented every line in /etc/sane.d/dll.conf except `net' and
`epson'; my epson.conf says:

usb /dev/usb/scanner0
USB /dev/usb/scanner0
usb 0x04b8 0x0110 

and my /etc/modules.conf says

# alias char-major-81 scanner
# options scanner vendor=0x04b8 product=0x0110

I have tried with one or both of these lines decommented, no change. 
Any ideas where to look now?  The scanner works on a Mac OS-X machine,
so seems OK hardware-wise.

Thanks for any help you might give.


Alexander Jolk         /         BUF Compagnie
tel +33-1 42 68 18 28 /  fax +33-1 42 68 18 29