[sane-devel] saned on Gentoo 1.4: disable IPv6?

Julien BLACHE jb@jblache.org
Mon, 22 Dec 2003 15:04:36 +0100

Wolfgang Fabics <wolfgang.fabics@chello.at> wrote:


> - Tried to start saned (as usual) from xinetd, which started without
>   errors... but saned did not start when connecting to 6566/tcp
>   ("connection refused"). So I disabled xinetd completely and tried
>   saned manually...

This is a common problem with xinetd, it seems some people get around
it and some don't. :)

> - ...and found that saned doesn't start at all without debug parameters.
>    saned -d gives me:
>    [saned] main: [1] bind failed: Address already in use

Which is no problem unless you see another "bind failed" message. This
is the second bind() attempt in a loop (hence the [1]), and at this
point the v4 port is already bound through the v4 mapping done by the
IPv6 stack. (at least on linux, on BSD this isn't true AFAIK, so both
bind() calls succeed on BSD).

> - But at the same time, the following happens to saned (I do not run
>    1.0.13 bcs it is not in the portage tree yet, and I want to keep at
>    least 'this' system somewhat tidy ;-):
>    [saned] saned (AF-indep+IPv6) from sane-backends 1.0.12 ready
>    [saned] check_host: detected an IPv4-mapped address
>    [saned] check_host: access by remote host: ::ffff:
>    [saned] check_host: remote host is IN_LOOPBACK: access granted
>    [saned] init: access granted
>    [saned] init: access granted to @::ffff:
>    [saned] process_request: waiting for request
>    [saned] process_request: got request 1
>    [saned] process_request: waiting for request
>    [saned] process_request: got request 10
>    [saned] quit: exiting
>    Pop goes the world, no more saned 'round here *sob*.

Debugging mode is just that -- debugging. In this mode saned exits as
soon as its job is over. In your example the job was to return a list
of scanners, which saned did without error.

> So, my questions circle around that IPv6 thing in the first place:
> Despite the fact that I have disabled IPv6 on my system (USE="-ipv6),
> the sane-backends' ./configure script claimed
> "checking whether to use IPv6... yes"
> How come? And how do I turn that off? Didn't find anything in the

./configure --disable-ipv6

But IPv6 is not your problem here, it's the xinetd configuration that
poses problem. And IIRC this kind of xinetd problem existed before the
IPv6 patch to saned...

I'm not using xinetd, so I can't help you much, but that's already
been discussed on the list a couple of times.


Julien BLACHE                                   <http://www.jblache.org> 
<jb@jblache.org>                                  GPG KeyID 0xF5D65169