[sane-devel] Linux 2.5.62

Stian Jordet liste@jordet.nu
25 Feb 2003 13:57:08 +0100

tir, 2003-02-25 kl. 12:24 skrev Henning Meier-Geinitz:
> Hi,
> On Mon, Feb 24, 2003 at 10:22:25PM +0100, Stian Jordet wrote:
> [I wrote]
> > > But it seems to be connecte to /dev/usb/scanner1.
> > > 
> > > Fix the config files (plustek.conf/epson.conf).
> > > 
> > I have tried both.
> So does it work with /dev/usb/scanner1?

Nope, exact same error :(

> > You have any idea why it want scanner1 in 2.5.x and
> > scanner0 in 2.4.x? 
> No idea. I can't reproduce that behaviour with 2.5.63. Without devfs
> (device file system), it works just fine. With devfs enabled, the
> device file is named /dev/usb/scanner48 (because of the minor id).
> That's a bug but I don't think it's relevant here. Enabling "dynamic
> minors" works with and without devfs.
> So do you use devfs and/or dynamic minors? Dynamic minors is in the
> USB section, part of usbfs.

I do not use devfs, but I do use Dynamic minors. I'll try to compile
without it.

> If you want to hunt the bug, can you enable debugging in the scanner
> driver (drivers/usb/image/scanner.h)? Please show me the output in
> syslog. Does sane-find-scanner find the scanner at /dev/usb/scanner1?

I will...

> > I'm using 2.4.21-pre3, which is working very good.
> > But I can try pre4.
> If it works, no need to upgrade.

You said that the 2.5.62 and 2.4.21-pre4 driver were mostly the same, so
I thought I could narrow it down. Oh well.

> > Hmm. Thanks anyway. Since there is no known issues, it's just my
> > setup, I guess.
> The allocation of minor ids is different in 2.5.*. So there may be a
> bug.
> Generally speaking I recommend to use libusb instead of the kernel
> scanner driver, at least in 2.5.*. The kernel scanner driver in 2.5.*
> may be removed at any time.

I get the same issues with libusb:

[plustek] Checking for 0x04b8-0x010f
[plustek] Checking for 0x04b8-0x011d
[plustek] Found device at >libusb:002:003<
[plustek] open failed: -1
[plustek] sane_get_devices (0xbfffe868, 0)
[plustek] sane_exit

chevrolet:~# sane-find-scanner 

  # No SCSI scanners found. If you expected something different, make
sure that
  # you have loaded a SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x0731, product=0x0528) at libusb:001:002
found USB scanner (vendor=0x04b8 [EPSON], product=0x011d [EPSON
Scanner]) at libusb:002:003

Hmm. Weird, since everything works perfect in 2.4.x. But quite a lot of
other thing works better with 2.5.63 now, so I prefer to use that...

best regards,
Stian Jordet