[sane-devel] Microtek ScanMaker 3700 SANE 1.0.9 and Mandrake 9.0

Henning Meier-Geinitz henning@meier-geinitz.de
Wed, 1 Jan 2003 14:51:44 +0100


On Tue, Dec 31, 2002 at 01:29:55PM +0000, David Hostetler wrote:
> Following Henning Meier Gennitz' suggestion (sorry if I misspelled) I ran make 
> distclean after uninstalling the 1.0.9. On my own initiative I ran rpm 
> - --rebuilddb to clean up all the old rpm stuff. And then I rebuilt 1.0.9 with 
> some success. I can access the scanner as root. I then read the man 
> sane-sm3600 manpage, and the hotplugging howto on the sm3600 backend site. My 
> logs show what the authors seem to think I should see, but I still have no 
> user level access to the scanner.

See man sane-usb. sm3600 uses libusb, so the permissions of the usbfs
must be set (/proc/bus/usb). The easiest way is to set option
devmode=0666 in the usbfs entry in /etc/fstab.

> scanimage -L flat out won't see the scanner and xsane dies just as it begins 
> to try to detect the scanner.

If the frontends behave differently, that's usually a sign of multiple
installations of SANE (or some trouble with dynamic loading).